Having trouble editing motion paths

Hello everyone. I’m just starting out on Animate 2, and ran into difficulty when editing motion paths. Perhaps there is something obvious I am missing?

The short of it is: I can’t seem to make motion paths curved.

After selecting a keyframe, the documentation states that one can then select the top-menu option, “Animation > Linear/Curve”. However, in my case the top menu only has the option, “Animation > Linear Motion”. There is no “Curve” option I can see.
The “Coord And Control Points” window always has the following options greyed out and unmutable: “Locked in Time”, “Tension”, “Continuity” and “Bias”. I can move the keyframes around when editing a motion path, but can not alter any of the parameters mentioned above. Further, pressing “P” does not add a control point, as the documentation states it should.

This is all while in the camera view, with the “Animate” and “Transform” buttons selected (and its “peg selection mode” DEselected.) I have tried this both on an animated drawing as well as on an animated symbol, with the same observed problems.

This is using the Windows version of the application. Build 7.9.0 (6015) (2010-09-15 03:47:49)

Thank you to anyone who can provide any help

you need to go into layer properties for the peg (or drawing) and enable 3D path.

Thank you TheRaider, that’s what I was missing. =)

On a related note, if I have already built an animation in a layer with its position property set to “separate”, and then I switch it to instead be “3D Path”, the old animation is lost (well, it’s still there if one switches back to “separate” of course.) I can understand unique tween information getting lost in the conversion, but is there a way to at the very least preserve the object’s transformations at the shared key frames when switching between “3d path” and “separate”?
Thanks again.

Well, the answer appears to be in the documentation:
“You have to lock or unlock your functions before starting
the animation. When you lock or unlock parameters, this does
not convert the functions from one to the other, but creates new
Looks like something I may write up as a feature request, then.

However another, related question has come up. On my machine, the Preferences option, “General → Default Separate Position” always behaves like it is checked, even when it is not. So I am manually setting each layer to use “3D path” every time. Has anyone encountered this before or know of something I may be doing incorrectly?

Toony Toon Toons,

Way off topic. Love the Star Drek, that’s some funny stuff. Keep it going.


Thank you, Gene. =)

Thank you for the advise.
Restarting doesn’t appear to change things for me. I’ve had the “separate” option unchecked for days. So just now I tried checking it and then restarting, and then unchecking it from there and restarting. The issue reproduced. I tried doing this cycle a few times, and it reproduced every time. I then tried pressing the button which resets all preferences to their defaults, and restarting. Issue reproduced.
Although the drawing layers always have separate functions, I notice that the peg layers are properly obeying the separate/locked preference settings.

Thanks for your help, Lilly. A description of the issue has just been sent to support.

Posting an update, just in case anyone else with the issue finds this thread.

Ron in tech support has cleared this up, stating that, “There is no way to set the default position to a 3D Path in Animate (Animate Pro 2 can do this)…”

& so I sent a request to rectify the documentation pdf to reflect this difference between the pro and standard versions of Animate 2. Note that the standard version of Animate 2 can still use the 3D path preference for peg layers, just not drawing layers.

I hope i can help…
you have to change the layer from a ‘separate’ path to a ‘3D’ path before you do any animation.
I do this by clicking the layer, then opening the ‘layer properties’ panel in my workspace. Click the radio button to select '3D path’
Now you should have the ability to create curved trajectories.
Create a straight point A to point B motion path first, then to turn that straight line trajectory into a curve, add a drag point to the motion path by making sure you are working in the camera view (and with animation button on), hover your cursor over the motion path and click ‘P’ on your keyboard.
You now have a grab point to pull your motion path into a curve (add as many grab points as you want by clicking multiple ‘P’ clicks)

I hope ive articulated this clearly enough. I have pulled my hair out in frustration over this recently, but think I have it right now. Critical point for me was to turn the layer into a 3D path BEFORE doing any animation bits.

Thanks SpidyTim. I certainly agree with the importance of your critical point. The difficulty I have is that it can be easy to forget that step before enthusiastically transforming the object’s keyframes etc.

That is, the issue this thread eventually turned into concerned weather or not the 3D-Path setting could be made the default selection, rather than having to manually set it via the layer properties or scripts.
The reason why a default setting is important is because, should the user forget to switch the layer to 3D-Path before animating, any animation created under “separate” mode will not convert to 3D-Path if the choice is made after-the-fact. If instead it were possible to specify 3d-Path as the default, user forgetfulness isn’t as dangerous.

I edited the preference to turn off default Separate and it didn’t show up right away, however after I restarted the application new elements were created with 3D path. Can you verify that it’s still not working after restarting the application?


Since I can’t reproduce your problem here it might be best to just email support@toonboom.com to resolve your issue. Make sure you mention the product, the build number (from Help > About) and your operating system.


Ah my apologies I must have been running my tests in Animate Pro 2. Thanks for clearing it up.