Harmony won't export some animations, saying there's no memory left

I keep getting a message which says no memory left that either crashes Toon Boom Harmony or my entire computer. I have about 30GB of free space. I don’t get why, but whenever it has big-ish files it won’t let me export it. And when it does, the fps is different than what I originally animated with. Help!

If your computer says there’s not enough memory it should be related with RAM not with free disc space. In Windows, if you open the Task Manager (can be opened by right-clicking the taskbar) you’ll see how much memory each software is using in percentage or MB. Current minimum requirements in terms of RAM for Harmony 15 is 8 GB. That’s a reference, you can use the software with less RAM depending on how heavy your scenes are. You can also crash the software even if you have more RAM, 16 GB, for instance, if you’re working with big scenes with a lot of 4K bitmap drawings for instance.

You might use all available memory just by playing a very heavy scene. In Premium, at least (the option wasn’t available in Advanced in v. 12), you can clear the cache without closing and opening the programme by going to View > Preview Manager > Memory tab > Clear Cache. If you have a crash due to insufficient memory just by trying to export you might have no other option but to somehow reduce the scene size. Or, of course, get more RAM.

Make your scenes as small as possible, especially considering your hardware limitations. Never make more than one scene/short/camera angle on a Harmony scene except if that’s absolutely necessary (like an amazing animated transition between two shots).


Luis Canau

Thanks for the reply, and unfortunately my crap laptop only has half the RAM that is needed. However, I did find out that with this laptop I can luckily upgrade the RAM to 8 GB, so hopefully it will be fine.

One small thing still bugs me that is slightly unrelated but it would be great if you could perhaps answer that too ; whenever I try to export something, it always is in 24 frames per second, regardless of what I animated with and what I put in to the movie settings. Is this related to the RAM problem or is it different?

Which version of Harmony are you using? Before 15 you can only export via Quicktime. If that’s the case, when you export a movie on the dialogue box “Export to Quicktime” you have, at the bottom, “Options/Movie Options”. If you click there, a second box will open with Video and Audio options. If you click Video > settings on top you’ll go to another dialogue where you can change whatever settings Quicktime might be using overriding your scene settings (it might be using the default or last used settings). If you put “Current” on Frame Rate that should work for general use. But better check next time, just in case.


Luis Canau