Harmony 21 Premium won't render alpha channel

I’m using Harmony 21 Premium on windows 10. I’m trying to export movie to quicktime prores movie, apple proRes 4444 with alpha channel at 3840x2160. I don’t have any color cards or anything in the background, in fact I have everything turned off but the character. The file always comes out with an opaque black background behind it, even when I drop it into my compositing software. I’ve also tried doing it through the write node, which gave me the same results but at 1080p. I’ve tried pretty much every combination I could think of, including adding a color card with an alpha of 0. Not sure what else to do.

What build of Harmony 21 are you on? You can find out under Help then About in the main menu. The latest for Harmony 21 is 21.1, build In Harmony 21.1 I tested outputting Apple ProRes 4444 plus Alpha(checked) using the Write Node in 1080 and 4kUHD, output was fine.

If you can, I’d update to the newly released Harmony 22.

Thank you, this is good to know. My version says “21.0.1 (17727)(2021-11-17 10:57:58)”
How do I update?

Log into you Toon Boom account on the main site.

Ok, I updated to "Version 22.0.0(18846) [2022-09-28 10:07:43] as well as updating Quitcktime.

I tried to render the same file, and got the same results. I wish I could just post my file, but the work is under NDA

In the Write Node try rendering a PNG with Alpha image or sequence and seeing if it outputs fine.

That does output correctly

I mostly output with image sequences, good to know that the PNG('s) export with alpha for you.

How about testing a new project making a simple animation like a circle(give it a color fill) going from one side of the screen to the other. Then output a ProRes 4444 w/ Alpha and seeing if it works. If it does then something in your other project is affecting the ProRes 4444 /w alpha output. It could even be a bug, then it would be best to contact support and see what they say. If it doesn’t work then maybe try reinstalling Apple QuickTime Link.

I did the test you prescribed in a new project, but it doesn’t export with alpha either, and I already tried reinstalling quicktime. I guess it’s time to contact support. How do I reach them?

Try desk@toonboom.com or fill out this form https://desk.toonboom.com/hc/en-us/requests/new