Harmony 16 keeps crashing on me when customizing the toolbar.

I prefer the flat toolbar, but Harmony 16 keeps crashing on me when I go to customize it.

I’ll be moving things over to the right side of the customize dialog, and when I apply it then causes the toolbar to go blank, then harmony crashes. When I open it again, the toolbar seems to have most of the items I want, except the animate button. When I got to customize it to bring the animate button back, it’s not listed anywhere.

I’ve attached an image of my .toolbar file - couldn’t attach the actual one. :slight_smile:


Try doing it in two steps…

  1. Select the flat toolbar preference.
    Save/close/re-open the program.

  2. Now select the toolbar to customize:

Yeah, that’s exactly what I was doing (the flat toolbar isn’t available w/out a restart).

I’ve customized the toolbar just fine in 15 w/out it crashing - I’m assuming something got in a funky state which is causing it to crash. Does the .toolbar file look out of sorts at all to you?

I can confirm my H16 Premium initially crashes when I switch to the flat toolbar in preferences, restart and then customize it.

I was able to move everything over, hit Apply and close the customize window then the toolbar went blank then moments later the software crashed.

Now regarding the Animate button, once I changed the toolbar option in preferences to flat and restarted the software the Animate button was still showing the non-flat options hidden in the spill out menu. Then I customized the toolbar, hit Apply and closed that window and the software crashed. Upon restarting the software the Animate button was missing from both the toolbar and from the customize window’s list of available items.

The only way to get the Animate button back was to select Restore Default Settings in preferences and restart the software.

That’s the exact experience I’ve been having o0Ampy0o. :frowning:

When I go into menu-Windows-Workspace-save workspace
before I close and re-open Harmony I’m able to customize the
toolbar without crashing.

Can someone post the details of their crash report?
I find that now I’m actually unable to reproduce the problem.

One thing that might have set off the crash is if you did all that
after installing V16 before rebooting the system. Always reboot
the computer after installing a new version of the software.

Ah! great suggestion, I’ll give it a try and let you know if that solved it.

Fingers crossed! :slight_smile:

Nope, unfortunately that didn’t solve it.

I rebooted, opened Harmony, switched the preference to flat toolbar, quit harmony, re-opened harmony, went to customize the toolbar, added the very first function over, hit apply, hit Okay, the toolbar went blank and harmony crashed. :frowning:

I had the software installed days before this event. I had started up and closed the program a few times. I had also shut down and booted up the computer a few times.

Yesterday when I attempted the customization of the flattened toolbar for the first time I didn’t save the workspace.

I just attempted to customize the flattened toolbar. However I tried the suggested “…go into menu-Windows-Workspace-save workspace before I close and re-open Harmony…” and as soon as Harmony restarted the flattened toolbar was the one I built the previous time when it crashed and, again, the Animate icon was missing from the toolbar as well as the list of items to customize.

But I was able to customize the flattened toolbar this time having performed the suggested sequence going into Workspace Save Workspace.

So the crash was avoided but I am missing the Animate button.

The first attempt’s Crash Report: The diagnostic report is very large. I cannot create a large enough image that you would be able to read online. I can create a text file or a PDF and send it to you if you describe a specific place so you can watch for it. (your work email?) Only the thread starter has the ability to attach files to a post on this forum.

I saw that the Contact Support link to a form has an option to attach files and have submitted a crash report.

Glad it’s not just me, then.

I’m having similar problems here to! Every time I try to move the bar with play button, the programs crashs!

Try renaming or deleting the preferences folder in case something got corrupted.

It’s inside
C:\Users[username]\AppData\Roaming\Toon Boom Animation on Windows
/Users/[Username]/Library/Preferences/Toon Boom Animation on Mac