Harmony 14 - import from scanner - unable to select/won't find scanner

hey everyone

I’m looking to import drawing from my scanner (epson perfection 4490).
its hooked up, turned on, however after selecting the “import->from scanner”,
in the pop up window the scanner listed is a second scanner of mine and I can’t select another.
even after deleting the scanner listed I can not select my 4490…

any ideas? im on harmony 14


Try deleting the TWAIN driver (if this is a printer/scanner combo also delete the printer driver) restart the system, then reinstall the TWAIN and printer drivers for the target device only.

Make sure the other device is not ever turned on during this whole process.

ok - so it seems I didn’t have a twain driver installed.
I found an epson driver - installed it and it was listed in harmony under “import->from scanner”.

however, no I’m faced with a new problem:

  • I get to the “scan drawings” pop-up window.
  • my epson 4490 is selected in the left tab, along with all the other settings (layer, import options, etc.)
  • hitting the “preview” or “scan” on the bottom right now opens up the twainscan (epson scanning utility)
  • there I can preview the scan, set the margins, etc. however:
  • once I hit “scan” (fist I get a pop-up window saying its set to scan multiple images and that some applications may not support multiple images, do I want to continue?), then:

nothing happens. I can click the can button all I like, it doesn’t scan.

  • clicking “close” in the twainscan returns me to harmonys “scan drawings” window.

any ideas how I can get the scans to harmony?
(is this a new thread/post?)


Are you on OS X or Windows?

I am on OS X. If I encountered this secondary set of problems I would go into System Preferences => Printers & Scanners and try to make adjustments there. Similar utilities exist in Windows. Something in your system is directing the scanner to the specific setting of “multiple pages.” First see whether you can resolve that. It might take care of the other problem where nothing happens when you hit Scan.

FWIW I have a multi-function printer scanner fax copier. Sometimes the driver acts up and when I want “Flatbed” it looks for something in the document feeder and visa versa. This happens with any software I am printing from. It is a driver/printer issue not the software’s.

thanks for assisting!

jup, I’m on OS X - and sadly I can’t find anything in the printer settings.
I tried switching the feed to the flatbed (which would not be multiple drawings) but upon hitting “scan” nothing happened either…

I’m not quite sure what to do - has anyone had experience with a epson 4490? it worked perfectly for Animo back in 2011.
what confuses me is that the interface/“Scan Drawings” - window in Harmony has the “scan” and “preview” buttons, but pressing on either of them opens the TwainScan.
shouldn’t it scan directly in Harmony?

thanks again for your time and opinion!

My scanner is a Brother and the Brother utility opens when you hit Harmony scan button.

Have you checked to see whether you have the very latest drivers for the scanner?

cheers again - awesome you’re still helping.

jup, got the latest driver installed - so when you scan, the brother utility opens, you set it up, hit scan, and it feed them through?
do you then have to close to return to harmony, or does it do that automatically once the scanning finishes?

I’m looking into toonbooms recommendation of “vuescan” - uninstalled the epson drivers, started up the vuescan trail… but harmony doesn’t recognise that…

if you have any tips just shout - and thanks once more!
should I figure it out I’ll be sure to post it…

I bring up the Harmony scan interface and click scan. My Brother TWAIN interface appears then I hit start. After scanning has finished I have a preview then hit scan. Once the scan is finished I must hit cancel in the Brother TWAIN interface before it closes and I am back to the Harmony scan interface. There I hit close. I am back to the Harmony interface.

What happens as a result of the process is that initially the new layer (option I chose as opposed to add to existing layer) appears and with each scan a new frame is added containing the scanned image.

Having the same problem as you, createdindust. Epson 4490, select from TWAIN in Harmony 14, get the popup, click preview, Epson utility opens, I hit scan but nothing happens. I noticed if i open Epson scan utility separately, I get a “select folders” icon to the right of the scan icon. It works when i do it this way but not when importing from TWAIN. No idea. And this is on a Mac.