Hand Tool Not Working

I’ve seen a couple of other people with this problem, but no solution that applies to me.
The hand tool is simply not working in Storyboard Pro, no matter what I try.

The hotkey set is the default (spacebar).
All of my graphics drivers are up to date.
I’ve tried uninstalling and reinstalling the program.
I’m on PC, not mac so there’s no computer hotkeys interfering with the tool in that way.

I bought an old version of storyboard a while back (1.5 I believe) and the hand tool is working fine with that version.
I just want to try out the newest version of Storyboard to see if it is worth upgrading.
Please help. This bug is making it virtually unusable.

Thank you for your time!

I may have found a solution: try reset preferences to default (Edit>Preferences> Restore all Defaults button) and relaunch or restart.

Wow, I can’t believe that worked!
It’s just bizarre because I didn’t even touch any of the preferences to begin with.
Well, better not look a gift horse in the mouth haha

Thank you so much for the help!

No luck on Mac :((