I am somewhat new to Studio, but I understand it well and have done some very satisfying animation using it. I am currently using version 4.0 on a Mac OS 10.4.11 with an Wacom Intos 3 graphics tablet.

The problem is, as I was near completion of a character’s animation, all of a sudden can’t use the “S” & “A” keystroke to advance the play; when I try to click on a frame in either the exposure or in the time line, the frame won’t click, where I want it to, instead it jumps to where it wants, and I have no way of getting to a frame where I have to edit or move etc.

Here’s what I tried to get around it:
I opened a new blank file and everything is normal, so I made a peg of the entire character and saved it to the Global Library. When I bring the character from the library, into the fresh new file the whole problem is back.

Does anyone know what caused this problem and/or how to fix it?

I would really appreciate help with this.

Many thanks.

Rob Mackintosh

Further, which may help…

This is a screen dump and I added notations to show that there seems to be a sequence to where the file will jump to. No matter where I click my cursor going from left to right, it will only jump to the spots I marked “x” in the time line, plus of course, the point where it physically was at the time of the dump.

It seems to be the main character (bette) element that has become corrupt. Every time I include just one of the frames from it in any file it stops the ability to select individual frames.

This element contains 6 drawings that were done using a brush line and then filled. There is one color being used that is a transparent value --and that’s as complex as it gets.

I have re-installed the program and opened from the new install and it is still corrupt when I use that element or any part from it. Does anyone know any known causes for an element to corrupt like that?


In talking with the Toon Boom Company, I was informed that there is an incompatibility issue with MAC 10.4.11 OS, which they know of and are currently working on a patch for.

The patch might be out in a week, but a word of advice for anyone who is working with TBS v4 on a MAC with OS less than 10.4.11. DON’T UPGRADE TIL AFTER THE PATCH. The MAC is a fabulous computer, and bless their hearts for it, but the MAC system for upgrading is an “in you face” approach --they have that pop-up, that persistently commands your attention until finally when you are busy and in a moment of weakness you click on it just to get some peace. (I clicked mine two days ago after I had it held off for about a week, and that’s what turned into my problem.)


We all have been there, and we all feel your pain. What a bummer!!!

I have over the years adopted a philosophy of OS upgrading which is “upgrade the OS if and only if the applications software, that I use the most, actually forces me to do so because it has been upgraded beyond the power of my current OS.” OS upgrades almost always lead application software upgrades which is a sure recipe for user pain. And quite frankly most OS upgrades are just looking to boost revenues for the OS vendors and really aren’t of much value until the application software catches up which is usually two to six months later.

Thanks for sharing the 10.4.11 warning, it may save some poor soul some future grief. -JK

Thanks for the reply, I’m just a bit surprised that I appear to be the only one suffering from this issue. But anyway its good to know that a fix is on the way.


Hi Rob,

I am not quite sure but we might have misunderstood the situation on your mail to support. There should not be any compatibility issue with Toon Boom Studio v4.0 on 10.4.11. The issues that are to be addressed in the upcoming patch are ones concerning 10.5.

In any case related to the other topic concerning your situation to have a workaround this situation. This is something related to the function editor and simply unchecking an option should solve it.

Best regard,


Thanks Ugo for this input…
Its good to hear that I can solve it without waiting for a program patch, as I am on a deadline to produce this animation.

I’m back in business, and for those who read this with the same problem, go to the function editor and uncheck the “Sync Current Frame” option.