Getting deformer chains to show in 14

I have to be doing something wrong here. I have a deformer on an arm, I select the deformer group, click the ‘Show the selected deformer chain and hide all others’ button, and it doesn’t work. Looking at the documentation, it seems like I should be able to click either the deformer group or the art being deformed and click either this button, or the ‘show controls’ button, or hit shift+f11.

Shift + F11 worked in Harmony 10, but didn’t in 12 when I tried, and still doesn’t in 14.

I need to pass these rigs off, and I need to be able to easily show others how to turn the deformer controls on and off without needing to go entirely into the deformer group, selecting the offset (or any of these modules) and then clicking the ‘show deformer and hide all others’ button. This is the only way I’ve been able to get these controls to show up so far.

Shift + f11 and the ‘show controls’ button still doesn’t work inside the deformer group, clicking on the actual deformer modules.


You now what, here’s what it says:

In the Camera, Node or Timeline view, select the drawing layer or deformation group or nodes containing the deformation chain you want to display.

Do one of the following:

    In the Camera toolbar, click the Show Control button.
    From the top menu, select View > Show > Control.
    Press Shift + F11.

All of this is wrong. I have to admit, I laughed a little at ‘you can easily show controls’. Is this a problem for anyone else, or is this a little special bug my copy of harmony has?

This happened yesterday as well as today, and I’ve restarted both harmony and my computer. Windows 8.1 (I know I know, not my choice) if that makes any difference.

Any help greatly appreciated!

Edited to add: ‘Hide all controls’, the button right next to ‘show controls’, works perfectly.

Please check Harmony / Preferences / Shortcuts / Deformation / Show Current Deformers.
Which shortcut combination is assigned there ? Maybe crete your own…

I am using F11 and that works marvellous…
Make sure you select with the Transform Tool the Drawing in the Viewport, then hit F11, or else.

There wasn’t a shortcut set, so I borrowed your f11 shortcut. It still doesn’t work when you’re on the actual deformation group, but if I click the art it will show up. Since that’s what the animators will be using to show/hide, that will work for me.

This doesn’t seem to be a consistent issue, because now if I click on the art and use the ‘show the selected deformer chain and hide all others’ button it works, when it wasn’t yesterday.

This is the same rig, and the same file.

I’ll see if it keeps happening.

Thank you for your help!