Fixing keyframes

Here’s my timeline… I made the mistake of forgeting to set my frames’ exposures to 2 before going onto the next keyframe.


X is a drawing, _ is a blank frame

So I select all the X frames, and Set Exposure to 2 and get;


Xx is a drawing extending for 2 frames.

What I want is this;


Now this might not be a big problem early on, but if happens around frame 200 of a 900 frame thing, then I’ve got 700 frames to doublecheck and make sure everything’s where it should.
Isn’t there an easier way to get what I want?

If I understand your situation correctly you have an exposure followed by a blank exposure followed by a different exposure and so on.

x1_x2_x3_x4_x5_ …
and you want

The easiest way to do this is to select each blank cell and replace it with the cell name of the previous cell. You can do this most effectively by using the cell tab in the properties panel. Just enter the number of the desired cell in the text box and press the return key and that cell will be placed in the exposure sheet at your current selected frame position. You will need to repeat this for each of the blank cells.

If you had started out with
without the blank frames in between then you could have just selected all the cell frames and extended the exposure to 2’s and you would have gotten exactly what you wanted but those blank cells are a problem. You will either have to delete them or replace them. -JK

i, having an old habit from 3d, where i used to work with one hand on the mouse and the second one on the keyboard, would do it in the following way:

- select one cell with the mouse (in the exposure sheet)
- control-c for copy
- click the adjacent empty one
- control-v for an exact copy of the previous cell into the blank one

this would have to be repeated for each cell pair. i haven’t found any ‘batch art’ to do it for the bigger cell sequence.

I guess I’m just used to Flash’s timeline. There, with a keyframe on 1, you set another keyframe on 3, and it auto matically extends the first one to the second frame.
It’s good, in a way that TBS doesn’t take frame exposures for granted like that, but if you’re animating on twos, then needing a blank keyframe inbetween should be an exeption, not the rule.
Maybe that should be an option the user can turn on and off.
It would be very helpful to me, for one!

Scotty A

i guess it’s always a compromise.
extending frames in tbs adds new cells after the base frame.
copying many cells overwrites everything for the duration of the copied sequence.

i think one can get used to work smoothly with those options. i personally don’t miss the feature you mentioned. and i’ve never had a necessity to batch change big parts of the film.

on the other hand, i insert many keyframes between existing ones, for instance when i work on an animation to a soundtrack, where my first draft looks like rare raisins in a still non-existing cake :wink: