File corrupted?

I got a new laptop and was transferring files and one file of mine doesn’t work? When I try to open it, it says " Failed to read in pipe with error (size = 4):
(87) ‘The parameter is incorrect.’ ". What does this mean?

This error (Cannot copy file (87): The parameter is incorrect) most often occurs when a file over 4GB in size is being copied (attempted copy, anyhow) from an NTFS or ReFS partition to a FAT32 partition. The error is because the maximum size of a file that can be stored on FAT32 is 4GB.
To fix this error, you try to do follow these steps:
1.Click Start to open Command Prompt.
2.Make sure you run Command Prompt as Administrator: right-click on the item and click Run as administrator.
3.When Command Prompt opens, type: chkdsk c: /r. Replace c: with the letter of the drive where Windows 7 is installed.
4.Press Enter.
photo editor

I actually have windows 10 and I tried what you said and the file still doesn’t open.

Hey, I had the same problem. It’s a temporary fix and it makes no sense to me, but here’s what I did.
I opened the file, went to task manager, and ended the “Media Server (32 bit)” task twice. It opened fine after that.
Don’t ask me how, but I hope that works for you as well.