Figuring out the proper way to do a mix of cutters, auto-patches, and pegs for an eye

I’m putting finishing touches on several of my first Harmony character rigs, and encountering issues in properly getting their eyes set up.

The primary parts for my eyes include the eye and white themselves, an iris meant to only appear within the white, and an eyelid that can go over the iris and the white but not the eye’s line art or anything else. Thanks to a topic I previously posted and the answers I got (At ), that issue has been figured out, but now I have another related problem.

For certain characters, I’m also trying to incorporate a small pupil layer in the center of the iris, which also shouldn’t be able to be visible outside of the eye white, as well as the iris itself. I’ve attempted to add this layer into the traditional node setup I’m now using for the other parts, but it’s been tricky. I’m at a point where the pupil mostly does what it’s supposed to if it stays within the iris, but if I move the layer outside of it, it displays over the rest of the head, despite the whole composite being ordered behind the head in Node View and the Z depth being at 0 for all of these. But since I mean to keep it within the iris to begin with, the big issue is that it always shows over the eyelid layer to some extent, which is not what I want.

I’ve included some sample images of the eye parts and my current Node View if anyone is willing to take a look and offer some pointers.

If you post the project (the entire folder) we can fix it. Easier to just show you than explain.

Sure. Let me know if there are any problems with the file.

Here you go:!DtJSzbYS!BwE5aXznQeBA2VN8XtWE2JJW1fxFYvKOMLhiVh6bnEE

I fixed one eye so you can see how it’s done. Also i added a connector for the eyelid that appears as a green eye with an L on it. It’s so that you can easily grab the eyelid when it’s fully back in the eye (such as not blinking or eyes closed). The visibility node makes it only visible in work mode, once you hit render or render preview it will go away (you can add these handles to anything, and you can also have a lower eyelid done the same way if you want).

I also advanced patched the left arm so you can see how joint merging is done that works with z-depth (for a more indepth of what i did see here: ).

If you cycle through the forearm drawing, drawing one will do the crease when it cuts into arm with a bend, and drawing 2 will be a seamless merge. You can make more drawings and edit it to your liking on the overlap.

You do have to turn on overlay/underlay layers since you dont have them enabled by default (or at least they are disabled in your layers, i had to re-enable them). It’s in preferences → advanced.

Lastly i suggest you watch all the videos in that learn.toonboom page. You really don’t want a huge titanic size comp connected to main like you have. Instead everything should be in a group, and each section of the characters all connected to individual comps and in their own groups.

Much appreciated. Thank you.