Exporting Sound issues

I have been having problems exporting sound. It seems that when I export to any format, it doesn’t go off what the way my time line looks but from where the sound was originally imported. Also, when I go to do a quick preview, there is no sound at all even whith the sound icon turned on. I have tried multiple different ways of exporting and am having no luck. Is there a bug that is causing this?

Jeramiah :-\

For playing sound, check if you can see the wave form visible in the Time Line. Also try scrubbing to hear if you can. If you have more than one sound card (such as on-board sound and PCI sound card separately), try using only one by disabling others in case it conflicts in the application for the output sound.

For exporting the sound, check if you can hear the sound. If you can not hear it, maybe you can check the sound setting when you export in as movie. If the sound plays but does not sync as it is in the scene, better try to export it without changing any fps option. Just export it as all frames and keep the same fps (ex, 24). Depending on the compression type and the resolution of your scene, there may be some lagging that can be experienced. Try export it as lower res in case it is related to the hardware issues.

The wave form is visible in the time line and I can hear it on the the frames where I would like to hear it when scrubbing but still can not hear in playback. I am using a Mac Book Pro that is less than a year old. One of my previous instructors has the same set up but uses Toon Boom Pro and he does not have this issue. When I export, I can always hear sound; it just doesn’t match the way my time line looked. I have not changed the FPS and left it at 24. For the compression type, I have tried DVCPRO50-NTSC, ANIMATION, and DVCPRO-NTSC. I have even tried changing the compressor quality to high and medium with no luck. Is there anything in the preferences that I may need to change or am I missing something when working in the sound editor? Thanks in advance for helping me figure out this issue. I would not like to have to re-cut the sound and match it up in Final Cut like my instructor suggested.


Hmm. Could you tell me what playback you are referring in Animate?
In Animate, there are two buttons (options) for sound. Enable sound and Enable sound scrubbing. Check if at lease enable sound is active. There is a sound icon in toolbar that you can simply click both active. This should play the sound when you play unless there is some confliction of the sound card if you have more than one.

For fps issue, make sure you have 24 fps on your scene and also exporting it with 24 fps with proper sound quality to see if it works with 24 fps. To avoid display issue, try also in low res to see the differences. Then try different fps if you are using other than 24 fps. Hope this gives you some idea.

Yeah the sound issues do suck on Animate, I still have to figure out a problem with one of my animations, there must be a bug or incorrect docs. Why should you have to put it through Final Cut/Premier when the sound facility is on the animation software , one of the main reasons you got the software in the first place !! Anyone from Toon Boom elaborate please ?

I think you misunderstood. The way I was saying that you do not want to edit the sound. You need to fit the animation to the sound. If you have set your animation with 24fps with the correct timing with the sound in the scene, and then you have exported the movie with 24 fps, animation should sync with the sound. If it does not sync, there must be something not properly set or there is some lagging. So try this. Create a new scene with low (360 x 270) with 24fps. Depending on the length of your sound, extend the timing. Then import the sound (make sure to use uncompressed format such as .wav). From frame one, draw number 1 (you can use red color instead of black). Then 2 on second frame and so on to the last frame to identify the frame number. Then export it using Animation codec and the sound with stereo 44.100 khz. Then export it and open it with Quick Time (do not use other movie player since there is some lag possibly found with mov). Then check the timing of the sound with the frame. Go back to scene to check if it is correct. If this works, you can isolate the causes.
-Possible changes of fps
-Large size of the movie such as HDTV format slow down the play
-Possible format of the sound
-Codec although you have tested with animation
-Sound quality
-Movie player

Here is the information on my Mac.

Chipset Model: GeForce 8600M GT
Model Name: MacBook Pro
Model Identifier: MacBookPro3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 2 GB
Bus Speed: 800 MHz
Boot ROM Version: MBP31.0070.B07
SMC Version: 1.18f4

Sudden Motion Sensor:
State: Enabled


Type: Other Network Controller
Driver Installed: Yes
Bus: PCI
Slot: PCI Slot 5
Vendor ID: 0x168c
Device ID: 0x0024
Subsystem Vendor ID: 0x106b
Subsystem ID: 0x0087
Revision ID: 0x0001
Link Width: x1
Link Speed: 2.5 GT/s

Intel High Definition Audio:

Device ID: 0x106B00A0
Audio ID: 46
Available Devices:
Connection: Internal
Connection: Combo
Connection: Internal
Line In:
Connection: Combo
S/P-DIF Out:
Connection: Combo
Connection: Combo

Problem 1- The Play feature

In the sound tool bar, I do have both the sound and sound scrubbing turned on. The sound does match up when I try to play it in Open GL view but I can not hear it in Render view. I can only hear it when I scrub through the time line and it does match up when I scrub. (For this I am referring to the play button in the sound tool bar)

Problem 2- Wave forms in time line.

I have tried importing the same sound files in wav. format and aif. This brings up another problem; in the time line I can see the waveform for the aif. file but not the wav. file.

Problem 3- Exporting

I have tried working with both wav. and aif. and there seems to be no difference when exporting. My sound still does not match up. I have done the frame number thing like you mentioned and my sound still plays before it should. I have made sure that I have my FPS at 24 and am exporting at 24 FPS. I had my sound set up at 44.100 khz. I have exported as quicktime and opened with quicktime. I would also like to mention that I did not have this issue with Toon Boom Studio; no matter what format size I used for my projects.

When I installed Animate on my computer I did it online before I was sent the installation disk. Do you think I should try reinstalling using the installation disc? If I do this, would I still be able to work on the animations I have started.

Thanks in advance for helping me, I really enjoy animation and the best part is the final product which I am trying to achieve.

It is normal that you do not have a sound in render view since it is only designed to have quick preview of the result to check the result of the effects for example.

THe main thing is the sound does not sync in final render. Have you tried with low res?


Thanks for your time on this Juho, I am having exactly he same problems and I have tried quite a few times to get this correct. Do you have any problems at all when you export animations with sound ? Surely it shouldn’t be a matter of checking settings should it, if it scrubs correctly it should export exactly the same ? Thanks again.

It works fine to me. There must be something in the scene that causes this then. Is there any way to see the scene if possible?

Sent you an private message with the details on Juho. Please let me know if you haven’t got it. Thanks.

Thank you for your scene. By checking it, it looks like a bug in Animate. I never tried more than one sound track does not starr from the first frame (i think you have moved the sound back after import) with longer frame . It also happened to me with that situation >:(. Here what I have found so far.

-multiple sounds
-sound does not start from the begining by moving it manually from time line
-get more offset when the scene is longer

So for your case i think, you need to try only exporting the image and add the sound later in the editing application or split the scene into scenes when camera changes so that the sound can start from the begining of the scene. Then put them together after using editing software.

OK Thanks Juho, it’s nice to have it confirmed, shame about the bug though.

yep and hopefully it is fixed.

I too have been struggling with the sound synchronization problems. Having spent all morning trying to fix such an issue, I’ve discovered that if you import a sound that starts at frame 1 and extends beyond the other sounds (the ones with the synchronization issues) then the sound comes out OK in the exported video. I have tried this with some music (in AIF format), but I’m assuming that it could be file containing nothing but silence.

I hope this helps.

BTW, do Toon Boom ever realese software updates for bug fixes and, if so, how do you get them??

I do not know the exact date for update but Toon Boom normally sends an announcement for the patches or whatever you call it. In digital pro, the patch was available next to your product pages so if you are Animate owner, register your product so that you can access to download patches if the procedure is same from digital pro. For your sound issue, I have not tried that way but I remember that when I have moved the sound (not starting from the first frame) to later frame (ex, 10) and export them in range (ex, 11– 15), the sound was not playing due to streaming feature that does not have it in digital pro. So I am not sure if this is the same in Animate. Anyway, check that if that is the case.

Sorry, I have been out all week for a funeral. When can we expect this bug to be fixed? It kind of sucks paying for something and not having it work the way it should.

Sorry, I have been out all week for a funeral. When can we expect this bug to be fixed? It kind of sucks paying for something and not having it work to it’s full potential.

Don’t know. Toon Boom should announce in advance when it happens.