Exporting Background for Coloring


I’m trying to export a large image for a background on ToonBoom Harmony in order to color it and import it back as a Png file. I have a camera movement on the scene i’m working on and the exported image shows only the frame of the camera, which is alot smaller then the whole background.

I want to export the whole drawing in the exact resolution and size, regardless of the scene settings or camera frame resolution, so i can color it in photoshop and import it back as a PNG and have the camera move on it. simple as that. how do i do it?

So far I have only been able to export either the camera frame alone, or the whole drawing at the resolution of the camera which is alot smaller then the original size.

Please help, I really like this program and I am glad I Have made the transition to it from TvPaint.


The Link to Images feature is part of Harmony Server:

"If you are working with Toon Boom Harmony Server and all your scenes are located on a centralized server, you can also use the Link to Images option.

How to link the scene to an external image (Harmony Server only)"

Version 10:


Version 11:


I don’t know the reason…

in Harmony 10.3 stand-alone version, have this option.

but in Harmony 11.1 stand-alone version, have not this option.
only in Harmony server version have this option…


That’s so disappointing that standalone no longer has it. There were so many times on my last project I wished I could link to an external file. I hope this feature is in the new Harmony release.

Hi Bagam,
Try exporting to “Layout Image” and increasing the “Expand Render Area” percentage. This will render drawings outside of the camera view. As long as you keep the “Scale Image” at 100% this should be what you’re after.

Vector shapes are always hard-edged. There are “tricks” to smooth the line or shape like antialiasing or a blur effect in the software for rendering but the vector object itself is hard-edged.

If you have an image of a cloud that you’re importing into the software, you may as well leave it as a bitmap (raster image) because if you vectorize it you will just end up with a vector hard-edged shape painted with a texture bitmap fill. I can’t think of many reasons where this would be prefereable to the original bitmap.

Harmony 11 has bitmap brushes even so you can even edit your cloud drawing in it’s natural state inside the software.

Is the “Link to images” a Harmony Network feature only? I have Harmony Standalone and don’t see this option :frowning:

Ok I figured out you can vectorize high resolution bitmap images and it works well that way.

However when I try to import something with soft and smooth edges, like a cloud, the vectorization will give it sharp edges and that’s not good.
Is there a way to avoid that? or perhaps there is a smudge-like tool in toon boom for drawing which I can use to soften it’s edges?


In fact, you do not need to export images.
because you should use “File - Import - Link to images” menu.
so when you modify the images in PS, and then the images is automatically updated to the modified image in ToonBoom.
sometimes you need the right mouse button to select the drawing module in the network view, and select the ‘Recalculate All’, the images will update in ToonBoom.

To be safe I would make a copy of the project to experiment with. Not knowing the resolution and size this may not apply but how about setting up an additional camera to get a different shot? You can always resize a larger image. If you have to you can change the target/project scene specs in the copy just to isolate the background and get the image exported. I am not sure importing a file at the same resolution it was exported from the TB software will produce the results you expect. Have you brought one of these tests back in and placed it as the background?

Yes, no matter what I do it’s allways smaller then the original. The problem is that I don’t know how much shoud I resize the exported image to get good results. it has to be exact because the animated character interacts with the background.
It allways gives me a smaller result than the original.

Here are some options to experiment with:

Once you import the image select its layer in the Timeline.
Right-click and open Layer Properties.
Under Transformation => Scale check Separate and uncheck Scale in Fields if it is checked.
Open a window for Top View.
With the image layer selected manually reposition the layer from the Top View.

This may work. It may present new problems if the camera in animated. It may not be noticeable but you will be moving the layer deeper on the Z axis so its real position may produce consequences inconsistent with the illusion of the character interacting with the image’s content. Address that later. First see whether you can get something better going with your imported images by trying the suggestion above.