Exported Frames Alpha is Jumbled Garbage

I need to export frames with transparency. When I use Export - > OpenGL Frames and choose PNG4 I get my artwork with transparency, but the alpha is all random blocks of noise (as a programmer it looks like dirty memory) - please see attachment (it should only be red lips on transparent background)

If I choose PSD4, the same thing happens to the Alpha channel - its full of noise.

If I choose Export → Layout Image, choose PNG4 it works as expected - no problems with the transparency. But I need all the frames exported, and as far as I can tell that only exports a single image.

If I choose Export → Render Write Nodes, it exports TGA without an alpha channel, and I don’t see any way to choose a file format with alpha.

I hope there is a way to make this work, otherwise my evaluation ends here. :frowning:

OpenGL frames are screen renders and these never have any transparency information
regardless of the file format you choose. Do a regular export using
menu-File-Export-Images, under Colour Mode select “Colour With Transparency”

I don’t see a menu or option like that. Here is what my File->Export menu looks like:


I figured it out. In the network view, I had to hit yellow box on the Write node, and chose PNG4 as the drawing type. Then when I render using Render Write Nodes I get frames with transparency.