Error messages Can't import jpeg, psd, png

I know .psd, .png and .jpeg are fully supported but for some reason I get error messages
"Following errors occurred during insertion: 1- The following files are of unsupported size [E1218]" (after trying to import a .psd file)
importing .png generates a E1215 message

I’ve tried out a lot of options because I work with Pixelmator and exported the file as a jpeg and also a psd from there. When ToonBoomStudio 6 generated the error messages I tried to import the psd file into Photoshop Elements 9 and export it again as a .psd. Didn’t work
I imported the jpeg into iPhoto and exported it again with no result. While other pictures from iPhoto were imported. But I couldn’t use the drawing tools on them.

Then I uninstalled ToonBoom and downloaded it again. No result.

Maybe there’s a .plist or something like that that I need to delete??

It’s quite important to me that this works since I got a lot of art work that I created in Pixelmator (2.0) that I’d like to use as background or for animation purposes.

Thanks in advance

Adding to my own post.

Still the same problem but I’ve experimented a bit more.
I’ve created a two layer .psd file from scratch in Photoshop Elements 10. Saved it. Imported it in ToonBoom 6. It was imported but all of my Drawing tools except the zoom tool were grayed out.

I have returned to my original artwork (before I colored everything -and very beautifully if I may say so myself ;-)- in Pixelmator 2.0) and I could import the TIFF files I created in Toon Boom. My drawing tools were up and running.
So I guess I have to do the coloring all over again.

But I would still like to know what went wrong. Of course I’ll write the guys from Pixelmator too and see if they can shed some light on this.

But the question remains why I can’t manipulate any .psd, jpeg, tiff or png files that are exported from Photoshop Elements 10???

If one uses File / Import File… / and then imports the bitmap image…
Those original bitmaps can’t be edited with the Drawings Tools…
(all Drawing Tools are greyed out)
Switch to the Sceneplanning Tools - Select (6) for positioning / scaling the image…

Create a Drawing Layer / right-click (control-click) the first frame…
Import and Vectorize / From File… / navigate to the bitmap image /
In the Import and Vectorize Settings check With Texture / click OK…
(all the Drawing Tools will be available now)

It shouldn’t really matter if one uses Photoshop or Pixelmator as bitmap editor…


Thanks so much for clarifying this Nolan and spending time and energy on this! I get that part now.

As you can see I’m new to this and I’m trying to understand the interface, the way TBS works and what I can do with it. I bought the workout series, some documentation and also the excellent VTC training video.

There’s another part that I worked on for the last day that doesn’t seem to make any sense.
TBS is behaving erratically when importing .psd, .tiff, .jpg files and the like. I was able to import some of them without a problem while others would either stop the import process, generate an error message or let TBS crash!

Ideally I would like to be able to do my artwork in Pixelmator, export the file as a .psd and import it into TBS. TBS would then translate the layers into elements and I can start animating

1. I’ve tried exporting old artwork from Pixelmator into a .psd file.
TBS wouldn’t import it.
2. I’ve tried importing the exported Pixelmator .psd file into Photoshop Elements 10 and save it into a new .psd file. TBS wouldn’t import it.
3. I’ve tried creating some artwork from scratch in Pixelmator, save it as a .psd file. TBS has imported that once and translated the layers into elements. But when trying this again later, the same TBS wouldn’t import the very same file.
4. I’ve tried creating some artwork from scratch in PSE10 and save it as a regular .psd file. TBS won’t import it and generates an error message (E1218).
5. I’ve tried dragging the individual layers out of Pixelmator. They will be exported as .tiff files. I exported 6 layers. 5 of them were imported the way I hoped for using the Import/vectorize option. But the sixth layer wasn’t imported. I’ve recorded this process of importing one .tiff file without problems while the other either produced a grayed out OK button or an error message. See link below.

so I started to work on that:
5.a. I tried converting the file using preview into .jpg, .png and even another .tiff file. No result
5.b. I’ve printed the artwork, scanned it into a .jpg and TBS wouldn’t import it.
5.c. I converted the scan to .tiff. no result

I’ll keep working on this but at this point it drives me crazy. I hope I’m doing something really stupid and I’m not seeing the obvious because that would mean I can keep creating my artwork in Pixelmator and animate it in TBS.



Thanks again for your time and energy.
George Parker

Not really sure why you are having such problems importing bitmap images…?
It might be a good idea and contact the Toon Boom Team:

Personally, I have imported hundreds of bitmap images into TBS (version 5)…
Either edited with Photoshop CS or Photoshop Elements 6… without much problems…

Quit TBS… Delete the “.plist” File… User / Library / Preferences…
(drag it into the trash, if needed one can bring it always back)…
Run “Repair Disk Permission” with Disk Utility… Restart TBS…

Does importing via the Timeline instead of the Exposure Sheet make any difference…?


hi Nolan,

Did everything you said and I know how that usually solves a lot of these type of problems. Sorry to say it didn’t work here.
I emailed the ToonBoom support guys/girls copying much of my last post and added some details.
Furthermore, I added a link to the .tiff file just to see if that’s part of the problem.
If you’re interested in trying it for yourself;
Here’s one of the files that is ok (small: 1.5 Mb):
Here’s one of the problem files (about 85Mb):

I’ll keep you posted about the solution (I’m sure there will be one down the road).
Thanks again. And have a wonderful New Year’s Eve.


Well, I guess, TBS can’t handle such resolution… (4088 x 5592 pixels)
This kind of resolution isn’t really necessary, isn’t it…?

Reduce the resolution to maybe 1404 x 1920 pixels… or even lower…
This not only reduces file size a lot, but makes those images much better manageable…

To many images in to high resolution will not only bring TBS to it “knees”…
But might slow down your whole system in the long run…

Applying the above resolution everything worked beautifully…


Hi Nolan,

It worked!
I shrunk the file size of that single file and it was imported without a problem.
I hadn’t even looked at this and feel pretty stupid that I missed this. You’re absolutely right, there’s no reason for this kind of resolution at all. I just took some old artwork and jumped right in without thinking about this.

And I returned to the full document, resized it in Pixelmator and exported it as a .psd. It was imported as well.

So thanks for staying with me on this. Highly appreciated and I feel very relieved!!

As you know I’m a rookie at animation and look forward to explore this new ground. I’ve lived through many careers before and over the last decade I’ve been a successful motivational speaker (mixing comedy/storytelling/illusion/content) performing all over the world and my latest product is TheCreationGame. If you like it, I’ll send you a copy of the card deck. Just email me at:

Thanks again.

I use JPEG images in all of my PRE videos. My general videos consists of 720 x 1280 video on the right and a 1000 x 800 jpeg on the left. I first create my images and their labels in PNG format for editing layers. Once all of that is done, I ‘save as’ in .jpg format. Then, rather than loading the images to the Timeline, I load them to the Project Assets window. First the video is moved from Project Assets, and then to a video layer above the video.

If your jpegs are corrupted they shouldn’t load in any graphic app, but if they load in say Photoshop, GIMP or Fireworks and they will not be accepted by PRE, load them in one of those other apps and first save them as PNG and then reload the PNG and save as JPEG,