Error message and drawing confusion

Howdy –
Using Windows Vista –
After creating a new file in 4.5, renaming the main drawing “Leaf”, and then drawing my leaf, I extended to 32 frames, saved, and quit.
Then, when I reopened the file, I got this message:

"The file Leaf-2 is related to a drawing and could not be found. The file may have been moved, renamed or deleted. Further error messages will be suppressed."

So, I added some art to the second cell, saved, and closed again.
THEN, when I reopened, I got the same message, only this time it was regarding Leaf-3 instead of Leaf-2.
Is this a bug?

I am also wondering why I cannot copy and past any vector graphic drawn on the first cell into the next one and modify it in any view. I can draw from scratch in TB, but not reuse and modify the previous drawing. I can’t find any reference to this exact issue, but it seems odd that this doesn’t seem possible in Toon Boom, what with all the capabilities it seems to have, though I may have selective blindness here. :frowning: I am wading through a great deal of in-depth basic information (such as what “keyframe” means, which does not confuse me at all), over and over, but can’t seem to track down a straightforward hands-on how-to in either PDF or video format. Thanks for any info.

Don’t know about 4.5. But, I know Vista can be a nightmare to work with. If you go to the program file for toonboom, and right click on the exe file, the one that launches toonboom, right click it to open the dialog box, go to compatibility tab, then select Win XP SP3, then click apply. Maybe that will make a difference.

Also, something to try, create a new folder in your library and save the drawing into that folder. It will save it as a template. Then when you close TBS it will ask if you want to save changes to the library- select yes.

This will answer alot of your other software questions.
Fundamentals Part One

I may be misreading your problem with copying art from one cell to another but if I am understanding what you wrote this may help you.

Here are two ways to accomplish the task.

Technique 1:
In the drawing view window select the art to be copied using the select tool [1]. Use [CTRL]+[C] to copy the selected art ([CMD]+[C] on a Mac) next move to a new frame position in either the timeline or on the exposure sheet. Now click anywhere on or inside the drawing window frame, this insures that the window has “focus” which means it is the currently active window. Then to paste the copied art use [CTRL]+[V]. Your art is now pasted into a new cell different from the original cell and you can modify it. The important key step in this process is insuring that the drawing window has “focus” when you copy and when you paste. It loses focus when you do anything in the timeline or exposure sheet like moving between frames so you have to re-establish that focus each time.

Technique 2
Select the cell you want to duplicate in the timeline, right click to open the context menu and extend its exposure using the set exposure command “Set Exposure To 2” this will give you two frames in sequence containing your original cell.

Next move to the second frame of that pair of frames and right click to open the context menu and use the command Duplicate Drawing. This causes the currently selected cell to be converted into a new cell containing the same art as the original cell. You now have two unique cells in sequence in place of two frames of the same cell. You can now modify them independently. This technique is faster than the copy and paste technique and works great when you want to do straight ahead animating by duplicating a cell make slight changes to the duplicate and then duplicate that cell and so on as you animate a sequence. Once you get use to this method you will want to set up a keyboard short cut for the Duplicate Drawing command to speed things up. The keyboard short cut for Extend Exposure to 2 is [CTRL]+[2] ([CMD+[2] on the Mac)

Hope this helps you out -JK

TBS The Basics Part One

Speak of the devil: I just got the same error message. Really.

Not sure what caused it, tried to duplicate it and couldn’t. But all is well with the file- after the error message I put a dot in the scene and saved it again- then closed the program for safety measures and rebooted it- deleted the dot and saved again and all is good.

edit: guess I could say what I was doing at the time:

I had just finished watching a movie clip for a pencil test- deleted a few cells, added two not very difficult drawings, did another movie clip, saved the file and that is when I got the error message- it was a rather lengthy message too- of course I’d been working on this project for most of the day with multiple saves and back-ups.

Wowwww…I wasn’t expecting such a response – thank you!

jbrushes – I’ll try that routine and see what happens. It seems to be that the program just complains and then behaves well after that. And I totally FORGOT about the compatibility option!

Thanks JK – I remember reading about extending exposures, and then couldn’t scare it up again. Probably because I’d been up all night!

Things are going much better now – thank you VERY much!


Got it again, the exact message is:

"The file flour sack ink-132 is related to a drawing and could not be found.
The file may have been moved, renamed or deleted.
Further error messages will be suppressed."

I checked the “Drawing” folder and sure enough it wasn’t there. Something skipped a beat.


Don’t have a slightest clue as to what happened here. Is the TBS version on the disk a different build thats on the account download page?

Anyway, I reinstalled from the download version - opened the file saaved to a different place on disk then got rid of the backup and org. Everything is working fine now.

Any idea let me know- I’d hate to have to go through this every 30 saves.


I sent a message to support, asking about builds (maybe there’s something newer for 4.5 than what I’ve got?) – can’t get into my original account to have a look, although the forum accurately reflects my original registration date.

TB was looking for a file that hadn’t been created yet (in my NEW project), so the error message was baffling. I had started a new file - hadn’t created what was supposedly missing, as far as I can tell!

Maybe I NEED a challenge!

They will probably be able to get you into your account. I’m assuming the download from accounts would be the latest build for that product.

As for what happened- things really started going nuts. If I selected something in the drawing view, I couldn’t un-select it. I couldn’t move things around without it taking forever and way farther than I did. So, I just uninstalled everything- registry, old directories and ghost files before installing the downloadable version. I hope this puts the fix on it…

Strange how it happened right after I posted to this thread… I knew I should have knocked on wood…