easy way to preview render

I am aware you can use the “preview render” button in the display window but i find that is only an approximation (like not anywhere near perfect).

Is there a quick way to preview render. I hate having to set up a file and just set to render the one frame every time i want to this.

Is there is a quick way to just pop up a complete render of the current frame without saving it?

In the camera view, there are two preview options, both that look like little flowers on the bottom left-hand side. One of them, the grey one, which is on by default, is an OpenGL preview. That is quick preview that doesn’t display all the effects that you’ll see when rendering.

However if you toggle over to the blue flower (mouse-over and it says “Render View”), that is an actual software render, and will display all the effects exactly as they are when rendered. When you have the blue flower enabled, you need to either press the far-left icon (a circle or a circle with a check mark in it) to actually render that frame, or click and hold this button to select Auto-Render. With Auto-render enabled, it will re-render every time something changes in the scene.

Hope that helps!

yeah I was aware of that button like I mentioned.

There is no way it is the same as rendering for me.

I am suprised there isn’t a way to bring up a quick preview window (like after you export there is an option

You mentioned the “Preview Render” button, but you didn’t mention whether you had the OpenGL view active, or the Render view. You need to make sure you have the Render view button active in addition to pressing the “Preview Render” button in order to see the actual render.

When you do a preview render with the Render Preview button, it should do an actual render. So if you’re seeing something different, you’re either doing something wrong, or your software isn’t working as it should. Can you attach a screenshot? Go ahead and upload your screenshot to a free site like photobucket then attach the link here and we’ll be able to see it.

Other than this the only way is to do a render and play, but that will render your whole scene, not just a single frame.


http://destined.com/rendertest.jpg

bottom is standard opengl view
top left preview render in toonboom
top right actual render

Okay I can see your problem now. The only difference between an actual render and a software render is that when you do a software render, it does the render then sticks it into an OpenGL texture. From seeing your screenshots, I would guess that there’s a problem with your graphics card, possibly in its colour settings or openGL settings.

What OS are you running?
What graphics card are you using?
Does this problem happen with every scene, or just with this scene?
Are you up to date on your graphics drivers?
What are the colour settings on the driver?

To answer your questions

-XP
- Nivida geforce i think, I don’t remember the exact model
-It does happen with other scenes but I don’t use the preview view much as the opengl view is good for most things, i just wanted to be able to quickly tweak effect settings.
-yes
-No idea on the colour settings (and nice to see the non-american spelling of colour, rare on the net :D)


I would still like to make a request for future editions for a pop up preview window on request (partly because you can leave it up while you play with your scene.

Okay so to find out some more information on your graphics card, go to Start > Run… then type “dxdiag” into the run window. You should get a dialog that pops up. Navigate over to the “Display” tab, and either take a screenshot of this, or click the “Save all information” button at the bottom, which will save the info into a text file. Open the text file and copy and paste the “Display Devices” section here, up until the “Video Accel” field - no need to include all the “deinterlace caps” fields after it.

thanks for your help, but i just ordered a new computer so I want to see how it goes on that before worrying about fixing something that is only a minor annoyance to me.