Easiest way to export image sequences with _no_ anti-aliasing

I’d like to export sequences of images from quite complex scenes)with no anti-aliasing. I want the pixels in the output images to only include the colours in my scene’s pallete (no intermediate colours), just as the OpenGL View mode displays them. Assuming the scene contains very many drawings, whats the easiest way to achieve this?

In case it’s relevant to know, this requirement is to facilitate a post process in after effects.


You can go to File > Export > OpenGL frames if you want to export everything on your scene. If you want to export separate layers or groups I suppose you’ll have to deactivate which you want to not export each time since unlike exporting from Write nodes you cannot add as many Write modules as the layers you want to export.

Does it work for what you want?

Luis Canau

Thanks Luis, that gets me most of the way there!

The new problem I’m having is that although my scene is 3840 x 2160 px in size, the exported frames are only 2423 x 1363 pixels. In the OpenGL Frames export dialogue i tried selecting both the ‘Scene Resolution’ radio button and later the ‘Custom’ resolution option set to the same size. Both approaches get me 2423 x 1363 exported frames rather than full size ones.

Remember that:
Harmony Essentials has a maximum output resolution of 2K
Harmony Advanced has a maximum output resolution of 4K
Harmony Premium has a maximum output resolution of 8K

The xK numbers refer roughly to the width of the image in pixels.
so 2K =2048, 4K=4096, 8K=8192

In the compasison chart expand “Render and export”

There seems to be a bug or a limitation with OpenGL export. cbit got 2423 x 1363 from a 4K scene. When I test it I get 1848x1040. This is not related with limitation of Harmony versions, since we’re working with 4K scenes. It doesn’t export on the correct scene resolution when choosing export OpenGL frames. If I change the resolution to 8K I get the same 1848x1040 on export.

Luis Canau

I own Harmony Premium so I don’t think that’s the issue.