Drop shadow not showing in Render view


is there a reason why drop shadows will show in OpenGL view, but not in Render view in Harmony Premium 17 ?

Everything seems to be ok with my nodes, which are connected exactly as required (cf https://docs.toonboom.com/help/harmony-17/premium/effects/use-shadow-node.html?Highlight=drop%20shadow), and the issue occurs regardless of my opting for quadmaps or relular pegs.

I have been using drop shadows for a while, including with former Harmony versions, and they have always worked well so far.

Shutting/restarting the software and the computer didn’t seem efficient.

Could it be related to a specific setting in the preferences (in the Render tab for instance) ?

Thanks in advance!

I can recreate the problem on my version of 17 as well. Placing the ‘shadow’ node below the ‘apply-image-transformation’ will fix the issue.

I suggest using an ‘apply-peg-transformation’ node instead of ‘apply-image-transformation’ as that should work no matter where you put the ‘shadow’ node and won’t clip your shadow if the rig reaches the edge of the screen.

It works, thanks a lot! :smiley:

I had indeed confused Apply_image_transformation and Apply_peg_transformation nodes, my bad.

Thank you so much once again!