Drawings dissapear when parented to deform bones

I’m trying to rig a character in Harmony, and I’m trying to have a drawing follow the bones of another drawing. When I try to parent it to a bone, it doesn’t display anymore. I’ve tried to put it in a peg, put it in a KO, add useless bones to the drawing, and combinations of all these, to no avail. What am I doing wrong? I try to follow a tutorial that does this, and follow them to a tee, and I still have this problem. The only notable difference I see is that when I use the rigging tool to add bones, I have an extra layer than the tutorial called ‘Deformation Drawing’, where when he adds bones, it simply nests the drawing into a bone. thank you.

Which tutorial are you following and trying to duplicate?

Can you be more specific and describe what these drawings are of and what you are wanting the result to do rather than describing the approach you are taking to do it?

It would also be helpful if you could screen capture

  1. your Node window with the hierarchy displayed
  2. the Camera view before everything disappears
  3. the Camera view after everything disappears

Bump! THis is exactly the problem I am having.

You are using a broken version of harmony 14 (the only publicly released one) that breaks drawings/deformation if you make a deformer chain. You need to contact partner support to get a fixed beta 14.

Aaaaahhhh thank you so much!! I will do that!

Update for those who are interested (and/or others who may experience this problem in the future, although hopefully 15 solves all problems):

I contacted ToonBoom support & got the beta version of 14, which unfortunately did not solve my problem. I’m still waiting on a response from them since I noticed after-hours, but in the meantime I decided to clean up my “node view” so that I could fix this manually in the event that they can’t fix my problem. Added the bone rigging to my character’s arm to test and searched for the bones in the node view search feature. As expected, the bones were being created un-parented. They were classified as a separate “multi-port-in/multi-port-out” section that (in my case) in the node view appeared in the middle of nowhere, VERY far away from the rest of my nodes (aka I couldn’t even see my other nodes at all, even when I zoomed out like crazy). I was able to find a work around, although it is sort of annoying to have to do for every rig I make, but at least it works. In the node view, search for your newly created bones. Once your search has found them for you, select the group of bones you have just created, then right click, go to “Group” and then click on “Move to parent group” (or just press the hotkey “Shift-command-U” on a Mac (not sure about windows users)). I tried this hotkey combo in the layer view, hoping I wouldn’t have to find the bones in the node view every time, but apparently that doesn’t work. Hope this helps someone else.


I was running into the same problem. We are running a trial of Harmony 15 at work and my bone rig was not matching the tutorial. I found that bones were grouped, and when I tried to parent an arm to something inside a group (say, to a bone inside the torso), it disappeared.

Automatically Create Group is probably on!
Check here. It can be used to keep your interface uncluttered, but it seems to break my rigging.

In my Layers pane, I just right-clicked all of those groups and chose “Ungroup Selection” and my arm came back.