drawing tools windows 7

I am not sure how to post in a forum but here is my problem. I have tb5 installed on my windows7 computer and the drawing tools don’t work right. i have a jpg of the problem but dont know how to post it. there are white triangle marks throughout the line on some of the tools… text tool shows up as just sqares… brush tool has hard angles unless smoothing turned way up. i tried the software on xp and it works fine, but i want to use it on windows 7

It is possible that your graphics driver needs to be updated for Windows 7. Most graphics drivers will need an update after you upgrade to Windows 7.

If you want to post your image, upload it to a free site like photobucket and then post the link that’s generated here, then we can browse to it and take a look.


thanks lillyV for your reply!

well have been trying to post link to the drawing but been having a few problems. hopefully the link above will take you there. I have a pentium d with ata radeon x600 and drivers are up-to-date. i have tons of hard drive space and 4g of ram. i can use studio v4 with no problems on this machine with windows 7 and i can use studio v5 on this machine if i use xp. i dont want to have to choose between v5 or win7
thanks for any help anyone has to offer

Okay I was able to take a look at the image. At a first glance it does look like a graphics card issue for the drawing tools. Go to Edit > Preferences > Display and try switching between OpenGL and DirectX. Do you notice that it works better with one or the other?

For the text tool problem, does it show up as just squares for all fonts or just for certain fonts?

When you do an actual render, do these problems resolve themselves, or does the rendered image look the same as the preview, like in the screenshot? Do the lines look all funny like that even after you refresh - i.e., if you switch to the camera view then back to the drawing view, do the lines still look like that?

in preferences I have a choice between “opengl” or “direct3d” and neither choice made any difference. i could not see any way to try other fonts with the text tool. when i render my picture everything looks ok except the text still shows up as squares. thanks again for your help!

Okay so there’s a few more things I can have you try here.

1) Turn off the Windows Aero scheme. This is a scheme that windows uses for its mouse pointers, and this sometimes interferes with our display in our software. You can turn this off by going to Control Panel > Mouse > Pointers Tab > then select (none) under the drop-down list for Scheme.

2) Go to Edit > Preferences and try clicking the “Improve Pencil Rendering Performance” checkbox under the display tab. Does this help?

3) Edit > Preferences > Display tab, uncheck all the “Smooth” checkboxes. Does this help?

4) Last but not least, if you’re still having issues, try fiddling with the number for Video Memory Usage. Try putting it up a bit or down a bit and see if any of that helps.

Let us know how it goes.

Toon Boom Support

thanks lilly i will try… just gave back the license to put it back on my xp machine. tried it on my laptop as well which also has windows 7 and was the same problem… except text worked, but no menu options. have no menu options for text on v4 either on either xp or w7. v4 works great otherwise on both my windows7 machines. i am downloaded the trial version for my laptop to see if maybe its my software. am getting tired of moving the licenses around! thanks again will try all your suggestions and let you know.

V4 has not been tested on Windows 7, and is not supported under that platform. In your initial question I believed you mentioned TBS 5 - so I was under the impression you were using V5. To clarify, what version exactly are you using? And when you say XP, are you using 64-bit XP or 32-bit?

:slight_smile: THANK YOU!!! clicking the “Improve Pencil Rendering Performance” checkbox FIXED it… yeah!!! i have toonboom v4 and version 5 and have tried both versions on both xp and w7. v4 works fine on windows 7 and xp. the text tool still doesnt work in either version on the w7 machine… but the other graphics work fine now. i do however have to change the preferences each time i open v5 in windows7 which is an inconvenience but at least it works. thanks again for your help.

As to why the text tool isn’t working, this is very odd… If you’re using Windows 7 make sure you’re using version 5. Now, when you select the text tool, and you open the text tab to the right-lower side of the screen, what do you see in your dropdown-list for fonts? Do you see many fonts there? If you switch fonts, are you able to display characters on some of those fonts?

Windows comes with a stock set of fonts installed, so you should be able to switch to another font and try that. There are some fonts that won’t display properly in Studio, but most fonts should display just fine.

yes i do get a dropdown menu and did find some of the fonts that work! THANKS