Drawing shadows on painted layer without affecting the line art

Hi, my name is Simone, I’m Italian, and first of all I apologize for my english :slight_smile:
I’ve been using TB Harmony Advanced for a week, and I’m trying all the tool this amazing software can offer. I’m working on simple exercises, but i got some problems painting shadows. I’m working on frame by frame drawed animation, so I would be able to paint the shadows on each frame, without affecting the line art. The problem is that I got the line art on the same layer of the colors, cause I just drawed with the brush and the painted on the empty areas inside the lines. So, my question is: how can i paint on my draw without affecting the line art? or how should i organize my layers working on frame by frame animation? cause maybe i should make 2 layers, one for the line art and one for the colors.
I noticed i could use the stroke tool to create the areas where i want to put the shadows, but i can’t see the strokes i did on previous and next frames, even if I activate the Onion Skin.
Well, this is my problem. Maybe it’s something really simple XD but I really can’t find a way.
I hope I explained well my problem, thank you for your help and have a nice day


Are you referring to drop shadows (cast shadows) as opposed to shadow/highlight simulating 3D effect?

Each Drawing Layer has 4 sub-layers (i.e. Underlay Layer, Overlay Layer, Line Art Layer, Colour Art Layer).

You could keep the line separate on the Line Art Layer and use the Colour Art Layer for the fills.

You could use the Underlay or Overlay layers for the shadow.

You could also add an additional Drawing Layer to include the shadows.

also to see the stroke just press “k” on your keyboard.

Thank you :smiley: I didn’t use that layers…i just didn’t understand how to use that and I ignored them. But now I think I get it. I’ve looked for tutorials about that layers on the Learn section of Toon Boom site. But I noticed that if i draw on the Line art Layer, when I select the color art layer i still see the line art o.O but in the tutorial when he select the color art layer the line art just disappear. Of course i deactivate the preview of all layers, so i suppose I should see just the layer I select.

You can use 4 art layers in Harmony Advanced and Premium. By default, you only have on your interface the Line Art and the Colour Art (sub)layers. On the left of your image there’s an L selected and you have a C below. This C is the colour art, so you can switch from line to colour clicking on the icon or using the shortcut ‘L’. Since you seem to be working with vector lines you can activate the option Automatic Create Colour Art. That way, when you draw on the Line Art layer you automatically create invisible lines on the Colour Art layer that you can use to paint. Just make sure your lines are closed, otherwise you might need to close them manually here and there. You can also create colour art lines by selecting the drawing on the Line Art and click on the Create Colour Art from Line Art icon on Tool Properties (default shortcut *)

You can also use a separate layer for colour, of course, but in most cases I think it would make more sense to use the drawing Colour Art sublayer.

You can try the drawing view instead of the camera view because the art layers will display in slightly different ways. You can just see the Line or Colour Art or both if you click on the preview icon (or press ‘P’) - and use the onion skin just with colour or just with line or with both. You do have similar results on the Camera View activating the icon Current Drawing on Top.

As for shadows, you could use your Overlay layer. To activate Overlay and Underlay you have to go to Edit > Preferences (or Harmony > Preferences on a Mac) Advanced tab and click on the first box ‘Support Overlay and Underlay Arts’.

But for shadows I think it’s better to create a separate layer, because it would be more practical to apply effects. You can, for instance, add a ‘tone’ effect via the Network to the shadow layer.

Some of these options depend on the work you’re doing and the results you want.

Luis Canau

Funny, when I replied I didn’t see any other replies here, but after they appeared “3 hours ago”. Well, now you have some repeated info.