Drawing files disappearing

I’m using TBS 6.0 on Mac OSX 10.8 with Mountain Lion. I’ve never had this problem before, but today when I opened some of my animation files I got this error message:

The file (drawing name) is related to a drawing and could not be found. The file may have been moved, renamed or deleted. Further error messages will be suppressed. [E1002]

When I opened the file, sure enough all instances of that drawing were gone. When I went into the filepath and looked for the drawing in the package contents, the file was not there. This has happened three times now. One of these times, drawing-4 was missing, so I closed TBS, reopened the file, and drawing-4 AND drawing-3 were now missing. When I noticed this, I went into Time Machine and restored an older version of the file from yesterday. Opened it, same error message. No drawing file in the file path. It’s like Toon Boom is eating my drawings.

Please, please help. I’m afraid to work on any more files, lest more drawings disappear.

I had the exact same thing happen to me on a PC two days ago, except mine was drawing-1 that was missing. I am also scared to work on any more files!

Do you remember what you were doing with this drawing during the last edit session before the file went missing?

Was the software force-quit after saving?

It was a while ago, but I’m assuming I was just exporting the movie in the last edit session. Prior to that would’ve just been working on timing. So yeah, I have an exported .mov version of the scene WITH the now disappeared drawings in it, but now I need to go back and fix some timing things and the drawings are no longer there.

I’m pretty certain there was no force-quit involved in those sessions. I could be wrong but I don’t remember so.

Make sure that you only work on projects located on the internal hard drive of the system, not an external drive, USB drive or network drive. It may be that some of these media are not keeping up with the data flow when you are saving.

You are certain that you received no error messages when you has saved prior to noticing the missing drawings?

The files were on the internal drive. Yeah, and I didn’t get any error messages when saving the previous time.

Thankfully, it hasn’t happened again since, but it would still be great to sort this out in case it happens again.

I too have the same deal going on.
Have TBS 7 installed and the last two times I made a project in it. It will randomly start forgetting certain layer elements. Seems like every time I open it there is another layer lost. Soon it will be all gone. Awful doing timely work on a animation and a whole layer vanishes. Ive not had any error while saving. No crashes while working on the project. This is not saved on a external hard drive. I’ll reopen the file to another time and its just… Gone.Shows where I have my frames but nothing is there in the camera window. Is there any sort of update I need to fix this problem?

I’ve been having to resort back to TBS 5 just so I know I’ll not loose my projects. Sucks upgrading to have something that I cannot rely on.

For those of you who have not already downloaded and installed the service pack (7.1) download and install it from the “My Downloads” section of your member’s account.

If you still continue to have these issues, there must be some common factor.
Please post the exact version of the O.S., where on your system the project folder is physically located, which antivirus program is installed, the version of Quicktime installed and any other relevant factor you might consider important.

I’ve got pretty the same problem going on like trelisM_15035. Only maybe one week ago, I’ve got a TBS update because I had a problem with kind of flashing red parts in exported videos. This is fixed now, everything works properly after export, but now I’ve noticed that drawing files just dissappear, suddenly. I’m currently working on a project with several scenes (6 so far, but they’re small, maybe 400 frames or so). One evening I imported a puppet from my global library which I drew some days ago, and in the scene I added some more drawing parts. I put it into motion, saved everything, no problems or error messages, everything worked properly. The next day I wanted to reopen the file and have a look to the animation, and the error message E1002 showed up, the drawn parts were all gone. I still see the drawing elements in the timeline view, but there are no longer drawings in them, empty frames only… It happened without any relation, weird. Another day I made up a cut-out-puppet, set pivots and stuff, added a peg element for further animation. But because I wanted to improve it, I didn’t add it to the global library yet, but left it in the project where I’d drawn it. The other day, I reopened the file and everything was just gone!! And I’m absolutely sure I saved everything before I quit TBS. Honestly, I’m pretty afraid to spend time now with drawing and animating parts when they’re suddenly gone after a while… Help…
Some dates:
TBS 7.1, number 7.1.18452
QuickTimePlayer Version 7.7.3(1680.64)
Trend Micro Worry Free Business Security 17.0.2316
Windows 7 Professional Service Pack 1
I’m a little frustrated that I’ve got problems again after another bug just has been fixed…

How do you download 7.1? I have version 7. I looked in my downloads and it just has what I bought. I’m so lost

I guess I’ve found the reason for one incident, because the same problem’s just happened again, and it was clearly my fault: after I drew my puppet, set the pivots and so on, I stored it in my global library and took it in to another scene later. There I needed another part for my puppet, so I added a new drawing element. I copied in there a drawn part from another drawing element and added the remaining lines and things, colored it and so on (instead of painting the entire new part, I thought it would be easier). Because I didn’t need the other drawing element anymore for this scene, I deleted the drawing element. But wait: I used a part of this deleted element in my new drawing. So now, even though I painted the rest on my own and I could save the file without any problems or error messages, there was this well-known error message showing up when I opened the file again and wanted to see my animation. The new added drawing element was all empty, but I could still see the frames. So I guess this is the reason, at least it makes sense to me. BUT: the other time, where a entire puppet went away after I patiently cut it out and composed it new with all the parts and pivots, but didn’t store it in the global library yet because I wanted to improve it further, I totally don’t understand why it was gone… No copies, erasures… So, there’s still one problem unsolved, but the disappearance of the single parts, in my case I guess, is comprehensible. I hope my explanation is understandable for you… :slight_smile: I’d still be glad if anyone’s got an idea for the other problem.

There are other potential causes that I forgot to mention…

  • If you move the project folder or global library location while your
    project is open or unwittingly open two instances of the same project
    this could happen.

  • Perhaps an antivirus program with very aggressive settings enabled could
    be blocking the writing of the files or worse, opening the project in sandbox mode (which will be deleted after you close the program).

The same thing happend to me.
I could identify one thing in common.
I sent an animator a scene from Mac to Pc with a character called “DUEÑO” and when he opened it, the character layer contained no drawings. At first we did not know what was the problem, but then I send him another scene where there was no character with the letter “Ñ” and he could open it.
Perhaps one reason that happens is the letter “Ñ”

Generally you should avoid spaces, accented or special characters because these will cause problems in your project. Only a-z, 0-9, “_” and “-” are safe for naming anything used in or with the software.

Additionally, if you are sharing projects between Mac and Windows systems it is best to name everything in lower-case only because Mac (more importantly Linux on which OSX is built) respects case-sensitivity wheras Windows does not. Naming everything in lower-case ensures that elements are seen the same way on both Mac and Windows systems.