drawing+disabled glow= exported drawing at different position

I am using animate pro 2

when I export to quicktime using jpg or qicktime formats, I found that a layer from the background seems to be in an advanced layer position (in the front).

I checked the render view and there it is displayed correctly.
I checked render view, composite, write and display are correctly.

I found that the network view I have the drawing tvg, and then a GLOW efect disabled, which is between the drawing tvg and the composite module.

if I enable the glow effect, then the layer is rendered in its correct position.
if I disable the glow effect, then the layer is rendered in the front of all the other layers. its position when rendering has moved to the front!

I dont know…it is correct?

thanks a lot
;D ;D

Depending how you export, it either consider the connection of read module from the network (when you export>render network) or the display (when you export>movie) that you select. And render view shows with the one using current display is selected. And I assume that you already have checked this.Other possibility is the illusion that looks behind due to the transparency. Try changing the transparency option in Glow as 255 for all RGBA so that there is no transparency or color (it should look white since RGB is 255) that the result in render view and export to movie should have the same result. If the result of the render view and camera view is different in (front/back) order, check if you have triggered ‘current drawing on top’ on and select bg element.

Hi, i have worked all project using by default display all.I am just using a)only one display module.b)by default the option: display all is enabled.in this condition a+b is when the problem happens.because if change the option to “display” it is rendered correctly. If I set the option to “display all” it is rendered in the first position only when the glow module is disabled. If the glow module is enabled in “display all” it renders correctlytvg–> glow—>---------->composite—>{write,display}All modules are connected to the composite, then the composite to the write and to the display module.there is no 3d space in the scene.the layer without transparency happens the same.is not an effect because the drawing is across the drawing and it is displayed over a lot of layers…current drawing on top was not used…Is it normal that having only one display and using display all, if the glow is disabled, the tvg is set in its first position? but if I use display only, it is displayed correctly,but not using display all?..disabling the effect breaks the order to the composite module set?or am I missing something?thanks a lot :slight_smile:

Basically you can preview what the different displays will look like by doing a render preview with that display selected. Make sure to show the “Display” toolbar. Then, if you do a render preview with “Display All” in the dropdown menu, you will see that if you do a display all it shows that layer in the wrong order. You definitely need to make sure to select the correct display node, and this display node should be in the same position as your write node. As you have noticed, using Display All does not take into account the appropriate compositing from your network view. The Display All feature was originally created for Animate, not Animate Pro, so that a software that doesn’t have a network view could still use an appropriate default display. With Animate Pro, the default value should be “Display”, not “Display All” - I just verified this by creating a new scene - when I do this, the default display is indeed the correct default “Display” node.Was this a scene that was originally created in Animate, by chance?In any case, the solution is simply to use the appropriate display node, and you will get the correct result. And of course, you can preview what your quicktime movie will look like by doing a render view with the correct display node selected.~LillyToon Boom Support

http://www.em.edu.mx/tb/defdis.pngoki, so using animate pro only “display” should be used.in this graphic if “display all” is enabled and the glow effect enabled, it is displayed correctly, but if it is disabled the effect, the layer is displayed at different positions… this was a scene created in animate pro. but at the end I only finished using one display in this scene.ok, its different logic used in “display all”: a disabled module separates the order of displaying that layer… so, I will use only render to “display”…thanks a lot :slight_smile: