Draw when Zoom in and out

Hello
When I draw, during zoom in and zoom out, lines become bigger , and I want to keep the same size of the drawing lines.

Is ‘Zoom Independent Thickness’ fixed or does it still make the line art disappear in render view?

That is going against reality. You are zoomed in therefore the lines are zoomed in. If you do not draw with the appropriate line scaling your linework will not be accurate.

If you use pencil lines you can change the way lines are affected by camera zoom. In the drawing Layer Properties check the Advanced (pre-Harmony 15) or Line Thickness tab and select ‘Zoom Independent Thickness’. You can also insert proportional values or animate them through time (v.g. allowing the line to get thicker but slightly less than the result of the natural camera zoom).

https://docs.toonboom.com/help/harmony-15/premium/camera/camera-truck-ins-line-thickness.html

I think this works both in Premium and Advanced.

This is also useful if you want to change the thickness of the lines of a whole layer without redrawing or editing the line thickness of drawings individually.


Luis Canau

In which version did that occur? I tried in v. 12 and the line was rendered a bit thinner than in OpenGL view when selecting the ‘Zoom Independent Thickness’ option, but that can be compensated by changing the proportional value from 1 to 1.3, 2, etc. I didn’t test it in v. 15 yet.

(FWIW I have always kept this option checked along with “Normal Thickness.” I have never observed it working at all as I expect it to).

In H15 when UNCHECKED the linework disappears in both OpenGL and Render views. I do not have time to check other versions this moment but I have 12 and 14 installed along with 15.

Checking “Normal Thickness” makes it visible.

I now tested this also in v.15 and the behaviour seems to be the same, with the difference being only the new tab for Line Thickness, instead of having those options in the Advanced tab.

The default is having ‘Adjust Pencil Lines Thickness’ unchecked, which, naturally doesn’t change anything.

Checking ‘Adjust Pencil Lines Thickness’ seems to make lines slightly thinner even at regular zoom, but that might be just the effect of having the lines anti-aliased.

Deselecting ‘Zoom Independent Thickness’ will make the lines normally scaled by camera zoom.

Adding value ‘1’ to ‘Constant’ will make the line slightly thicker, maybe closer to the perceived thickness in the OpenGL aliased view.

Deselecting ‘Normal Thickness’ will make the line disappear. This option has to be selected at the same time as ‘Zoom Independent Thickness’ for this effect to be applied. At first the ‘Normal Thickness’ option seems redundant, but you can use it with the ‘Zoom Independent Thickness’ unselected if you want to play with the values manually. For instance, changing the proportional value to 2 or keyframing that value to animate the line thickness during the zoom to your liking instead of the ‘natural’ zoom scaling or the zoom independent thickness.

If your line is vanishing in a situation where you have the ‘Normal Thickness’ selected that might be a graphics card or a Win vs Mac issue?


Luis Canau