Does Snow Leopard work with TBS V.4?

Does Snow Leopard work with TBS V.4?

Only TBS V5 will fully work with Snow Leopard.

How much will it cost me to upgrade to V5 from V4 if I am on a Mac?

Best,

Evan Jacobs

You can contact sales@toonboom.com with your question.


Simon.