deformation suddenly not working?

So I created a rig with several deformers on arms, legs, and the body. It was working great! No animation was done as I’m just designing right now. Then I saved and put my computer to sleep. This morning I go back to my scene, and the deformers are not working. I can bring up the skeleton, and I can move it, however its not deforming the drawings as it should. I checked in the render view and it is not functioning in there either. I checked the chains and they appear to be enabled and look normal. Anti-aliasing is off. I don’t know why it suddenly broke as I did nothing to it. Thoughts?

I presume you tried to exit the application and load you scene again ?
Any luck ?

If you already did that, it would be nice to get this scene in order to investigate.

Can you contact with this issue ?
Be sure to include the exact version and build number.
For example : Harmony 9.2.0 (7765)



Thanks for the reply! Yeah I restarted Harmony (v10), even restarted my machine, and it still persists. This has happened before on a totally different character, but I rebuilt the chain in that case. However, I want to know why this is happening so I can learn from it. I will contact support like you suggest. Thanks!

The only thing I can think of that I might have possibly have done was attach everything to a master peg after a rigged the deformers to the arms, legs, and pony tail. Would that break the chain at all?

So I must’ve added a duplicate drawing to the layers in question (I don’t remember doing this. I must’ve hit something by accident?), and the rig wasn’t working on these new drawings.

Thanks for addressing me, fgrossin. It helped me work through the problem! :slight_smile:

I had the same issue, except with no duplicate drawings… I even went to each deformation layer and tried disabling/enabling them individually. I stumbled upon a fix for my scene by right-clicking (PC) on one of the deformation layers, selecting the “enable” tab, and clicking on “enable all”. This fixed all deformations which were not working, though I’m still not real sure how it got switched off. Hope this helps someone in the future.

I had the same problem. I went to look at all the drawings I had of my left leg drawing and there were 9 drawings. I would select one, then move the leg and deformation bone. Nothing happened.

So, select next drawing and do the same thing. I finally found that the deformation bones were set up with the 4th drawing. When I had it set to any of the other drawings the deformation bones didn’t work.

Anyway, it will drive you crazy because you’ll feel you are doing everything the same (select Transform tool, Select Show All Manipulators). But nothing will work.

It’s got to be the wrong drawing. So go find it and make note which drawing you set up the Deformation bones with.

yeah that was definitely the issue. i’ve also learned that once a deformation chain is created, you can’t change the name of a drawing otherwise it breaks the chain.

in retrospect, what i was doing when i first encountered this issue was that I was hitting F6 which by default was dropping a keyframe AND duplicating the drawing. I didn’t realize it was doing this, and thus the deformer wasn’t “working”. I have since fixed this issue by changing my preferences :slight_smile:

How did you determine that you had a duplicate drawing?

If anyone runs into this same problem, I’ve found a solution.

If you make a new or duplicate drawing on a layer with a deformer on it, you MUST make sure that the Drawing Name is the EXACT SAME NAME as the drawing you created the deformer on, then just add a number “+1” at the end of it. (Ctrl+D to rename drawing.) Or else you’ll move the deformer and nothing will happen to the drawing.

I also had a different issue, where my deformer chains were turned off somehow in their own groups and prevented me from moving them at all. SCUDx24’s solution worked for me by expanding all the layers (Select All then press 9), Selecting All the layers, and turning on Visibility (A) to turn everything back on.

Hope this helped!