Deformation doesn´t show in camera and 3d view.EDIT:FIXED + optimize your view port

Hey, guys

EDIT: actually the bones work but the deformation only shows in onion skinning and render view.

the fast camera viewport only shows the onion skinning of the deformation, not the deformed object itself!

EDIT2: ok it works! it was just that i had to disable anti-aliasing, lol , i think that should b outlined in the popup that appears on that option !

EDIT3: hey just a heads up i just found out you can force antialiasing through the graphicscard driver for the opengl camera and 3d view.

you need to enable fullscene antialias in the opengl options in toonboom and then in you r graphicscard driver you add stage.exe and force it to use antialiasing( options depend on your gpu)

this is realtime speed and the preview is so much better with it!

I am sure there is value here lost in the edit confusion. Would you mind reassessing this experience and summarizing the key points in statement form? I doubt that many people have had a chance to read the original post and each revision as you made it. Maybe state your original dilemma then bullet point the information you learned that resolved it. I would love to know what you discovered and it may help someone down the line with a similar problem.

Thanks

Ok you´re right!

  1. my initial problem was that bone-deformation on vector layers(drawing/imported vectorized) didn´t show up in the opengl-view.

  2. this was due to the anti-aliasing setting in my toonboom settings!

IT NEEDS TO BE TURNED OFF!!! otherwise the deformation will not show up in the opengl view!

this little information should be implemented in the anti-aliasing checkbox popup information in the settings!

3)but with turned off anti-aliasing the preview quality is extremely bad, to the point where judging the final render output becomes an unneeded hinderence imho

4)so i tinkered around with the settings and the solution was to enable the fullscene-anti-aliasing settings (which doesn´t break the deformation tools) and then

  1. on every graphicscard driver you can add different games and force antialiasing and texturefiltering settings on them.
    Of course you can also add other 3D programs like 3ds max or in this case toonboom animate/harmony.

So just search for the right exe file in the folder (stage.exe)
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony \win64\bin

add it to the graphics drivers panel and force the highest anti-aliasing settings.

restart harmony and now you got a difference like night and day.
its not as good as the render output BUT its almost as good and looks damn fine and runs without any working-speed penalty!

thats it.

lol i´ve just seen the exact process for fullscene anti aliasing is outlined here:

http://docs.toonboom.com/help/harmony-10.3/?utm_source=ohstgm&utm_medium=InSoftware&utm_campaign=HAR_10.3#HAR/Stage/003_Interface/105_H2_Full_Scene_Antialiasing_Preference_in_the_OpenGL_tab.html

still hard too find that page from google