cut out animation - child peg rotation point changes position

hi folks

Got a weird problem when rigging cutouts.
heres what im doing

step 1, link hand as child to lower arm. (maybe shift element a few pixels to get better placement - when parenting some elements seem to shift a couple of pixels)
step 2, set rotation point and test for accuracy
step 3, rotation point set properly confirmed
step 4, repeat steps 1-3 on the lower arm.
step 5, rotate lower arm to another position then re-test hand rotation.

and this is where it all goes out the window. The futher i rotate my lower arm away from its start point the futher the rotation point, or the x/y location (relative to the lower arm) of the hand gets pushed out.

rotate the arm back to its start position and the hand works properly.
Rotate the arm away and the hand goes out of alignment.

Ive tried with parent pegs and with element pegs with the same result.

what gives? is it how i set up the artwork in the first place? (originally the artwork was scanned and imported on its side). There seems to be no logical reason or no explanation available in the docs.

is there things you should avoid when rigging?
eg: if the element is out of alignment is it better to reposition using the peg or the element?
if you accidentaly did a little bit of repositioning on both would this mess things up?
- i have a sneaking suspicion that this could be part of the cause. But with nothing available re: troubleshooting a rig, im lost.

Any advice out there? :slight_smile:

me again further testing reveals that is definately the peg rotation point that is changing - not the x/y of the element. As i rotate the lower arm, the rotation point of the hand peg is getting pushed further away

me again - yet againmore testing has revealed that the actual element is also sliding around under the peg. if i rotate just my hand i can see that at 180 degrees the rotation point has moved from the wrist to about half way into the hand.

Hey Frasermu,Just a couple preliminary questions:1) What tool are you using when setting your pivot points? -Always use the Rotate tool (from sceneplanning tools) to to this initially. Setting pivot points with the transform tool is only a temporary change.2) Is there a rogue keyframe somewhere on your timeline? if one was accidentally placed it could just be that your pivot point is gradually moving towards another keyframe further down the timeline. If neither of those proves any help, keep asking & I’ll do what I can.

hi thereyep - using the rotate tool to set the pointI only have 1 frame on the timeline so it cant be a rouge keyframe (i think).Im still at the rigging stage so havent got any further than frame 1.

quick updatetried the same process (building an arm) using the drawing tools in TBS (squares) and set and tested all the pivot points before parenting. This works fine.So its either my previous process or its my imported artwork (initial orientation placement etc)