Curving camera peg pan

I’m working on an animation where the first 120 frames the Camera Peg is stationary. At frame 121 I create a new keyframe and move the camera in closer to the scene. At frame 240 I add another keyframe so that the camera pans along following a walking character. For some reason the path of the peg is bowed or curved so that it looks like the camera is moving in and slightly up during the pan. Once it reaches the final keyframe the z distance is correct.

I cannot figure out why it does this and refuses to simply be a straight path along the x axis. I ended up having to leave the character stationary and moving the background elements to simulate the movement and make it smooth.

What is the solution?

Zeb, in the camera path editor you can set the tension keyframe value to 1.0000
this make the paht segments straight, next with the velocity editor you can change the segments velocity in multiple ways using the handles and preservating others straight. In top view result visible the straight segments and the acceleration done by change the velocity in the desired segments. In a test this works, but the software has a lot of variables to done very different results.
This will work well for you? I hope!

Best Regards

That did it! Thanks so much, Yoryo! I was just coming up against the same problem with a peg for a character. I just noticed that it didn’t seem to be moving in a straight line and when I turned on the show control option I could see that it was warped slightly. So I figured I’d check back here and see if some genius had answered my question–and there was your post.


in my almost a year stay here, i have seen this issue come up more than i think 5 times. perhaps the toonboom team may wanna consider fixing it.

You can change the properties (tension, continuty and biais) of the 3D path in the Coord. and Control Point View .

Also if you prefer that the default is straight lines between keyframes you can change the Preference>Camera Tab>Control Point Tension to 1.

I don’t think a fix is needed it depends what kind of movement you want. If you are doing a plane flying away in an S path you would appreciate that the default is doing smooth curves. Since you have a preference you can change then you can set it to what you need most of the time. It was set to straight at some point and then we had complaints that it should do a curve by default.

The reason is that pegs are set by default to 3D path, which does interpolate smoothly between frames. There are a few different solutions. You can set the Peg to Separate, if you prefer that to be straight. You can leave it as 3D and adjust the tension on the line. Or you can leave it as 3D, turn on Show Control on the camera path, and create a control point. Drag the control point right next to the keyframe and it’ll flatten out the line.

I prefer the control point method, myself.


Indeed, as Steve mentions, there are many situations in which a 3D path is preferred. So there’s no fix to make here. It is simply an issue of making sure that users better understand these tools.

We could set it to Separate path by default, but I think we’d see just as many users upset about that change. You can also set the default yourself in the Preferences.