CTD on creation/opening of projects

System specs: Windows 7 Ultimate x64, AMD Phenom II x4 965 3.40GHz quad-core CPU, 16GB memory, AMD Radeon 6850 video card with 1024MB memory. Virtual memory is 32GB, page file is 16GB.

Just in case - CTD means "Crash To Desktop"

I have Toon Boom Studio 6 SP2, installed via download. At first it worked just fine on Direct3D settings (OpenGL produced some pretty bad display problems, I’ve read that this may be due to my AMD video card so I switched to Direct3D and that was solved). However, within five days (registered on May 6th, 2011, support first contacted May 11th), I attempted to launch the program, got to the intro screen, and clicked to open a project… and the window immediately went white and TBS6 crashed to the desktop. No error messages, only the generic “Windows is searching for a solution” dialogue followed by the generic message about how the program has crashed.

At this time, the program will open to the intro screen, but cannot open existing projects or create new projects - attempting to perform either action causes an instantaneous CTD. All other buttons on the intro screen work as intended, and all dropdown menus function normally (File>New… opens the dialogue to name the new project and set format/framerate/size, but crashes once I click “Create,” and File>Open… opens the file browser, but crashes once a file is selected and I click “Open”).

I have tried the following:
•Direct3D rendering - no change
•OpenGL rendering - no change
•Run as Administrator on either rendering mode - no change
•NOT running as Administrator on either rendering mode - no change
•Compatability mode for Windows XP and Vista, every available service pack, for either rendering mode, as Administrator or not - no change
•Disabling hardware acceleration, for all above scenarios - no change
•Disabling Visual Themes under Compatability, for all above scenarios - no change
•Reinstalling the program but leaving settings/preferences in place - no change
•Reinstalling the program and wiping settings/preferences - no change
•Rolling back video drivers and testing all above scenarios - no change

At the time, I was also unable to access the forums while logged in, so I skipped to contacting customer support via email. However, now that I have access to the forums (I have no idea how this got fixed but it did so that’s no longer an issue), I thought I’d post this up here as well to see if anyone has any thoughts, or can think of something that I’ve missed.

I am still trying to find a time that I am able to get with tech support to take a more in-depth look at my problem (TeamViewer was mentioned, and I am familiar with that program), but due to ongoing schedule/time-zone conflicts I have not yet been able to do that. While I already plan on contacting tech support directly again when I have the time, hopefully posting here will provide some level of insight in the mean time. Due to the time that has passed since my initial contact, my support ticket appears to have expired, but I can still pull up the ticket number if that will help.

Thanks in advance for any advice or information you may be able to give.

I think you should still contact support for your issue.
If it is hard to contact them due to difference in time zone, you can try some on your own but may be little bit risky or technical.
By looking at it, the first issue may be due to the renderer type that if your video card supports direct3D, switching your render type will work. However, if the application suddenly stops working, it may be for many reasons including the change of your system configuration or missing components. Since it also crashes while you are trying to create a new project, it may not be related to the project itself.
For application side
-Uninstall Toon Boom Studio and make sure that you are deleting the preferences since may be related to the preferences setting.
-You can manually access your ‘regedit’ and delete folder related Toon Boom Studio if there is any left after uninstalling (HKEY_CURRENT_USER>Software>Toon Boom Animation Inc.>Toon Boom Studio X.X where x is your Toon Boom Studio version). You need to back up your registry before trying it.
-Reboot the machine to reread the registry. Again, there should be no Toon Boom Studio in Registry.
-Install latest video card driver
-Make sure there is no block from firewalls or anti virus application. You can simply disable them temporary.
-Then install Toon Boom Studio and change the renderer type as direct3D on welcome screen and then restart Toon Boom Studio. And then create a new project if it still crashes.
My s cents but if this does not solve your issue, better contact support

Thanks for the quick reply, juho!

While I’d already covered some of the possibilities you’ve mentioned, I had not checked the registry, though that should have occurred to me - even when I uninstall and delete preferences, it doesn’t ask for my registration key again on reinstallation, which should have told me that there’s something left behind.

The registry folder that you’ve described is not present after uninstallation, however, which means that whatever’s left behind must be somewhere else. A registry search has located “Animation-ish” folders under another directory, but I’m not about to touch them without knowing what they are. I know that Animation-Ish is a Toon Boom product, but I’ve never installed that, so I don’t know why that should be there.q

I have confirmed that it is not my project files to blame, however. As mentioned in my original post, Toon Boom Studio also crashes when I try to create a new project.

Everything else that you’ve suggested has already been tried.

Regardless, I do appreciate the quick reply, and I’ll just have to keep trying to get the time to contact support during a time of day that they’re able to help me.

EDIT: I found the problem reports for the crashes. Every crash after every test I’ve tried is the same, as shown below:

Faulting Application Path: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Studio 6.0\TBS.exe

Problem signature
Problem Event Name: BEX
Application Name: TBS.exe
Application Version:
Application Timestamp: 4d80e6f8
Fault Module Name: MSVCR90.dll
Fault Module Version: 9.0.30729.6161
Fault Module Timestamp: 4dace5b9
Exception Offset: 00030416
Exception Code: c0000417
Exception Data: 00000000
OS Version: 6.1.7600.
Locale ID: 1033
Additional Information 1: fb88
Additional Information 2: fb88eca5302f8448c2c8d00a892e9a8a
Additional Information 3: 673e
Additional Information 4: 673e89635d9de326f9e02042a32438d0

Last time I emailed support, I got a reply within minutes, but this time I’ve not gotten anything for over two weeks. Did I really leave that bad of an impression on you guys?

In any case, if anyone has any ideas at all, I’d be very appreciative, I’d really like to get back to working on the projects I’d started before TBS stopped working.

Hello Zach,

You really should email support@toonboom.com for this issue as it may require several back and forth emails to resolve but here is something you can try…

Try deleting you preference folder from:
C:\Users[username]\AppData\Local\Toon Boom Animation\Toon Boom Studio 6.0

Then open the software and make sure that you set the display back to Direct3D


I emailed support shortly after posting the original post, which is over two weeks ago now. Not sure what else to do if I’m not getting any replies.

As for deleting the preference folder, I just tested that, and there’s no change.

I guess I’ll send them a third email and hope for a reply.

On Windows the ATI graphic card drivers do a poor job with OpenGL. Also if your card is underpowered I strongly recommend disabling your Aero Desktop Theme and selecting one of the Basic and High-Contrast themes instead.

Right-click the desktop and choose personalize…

As has been stated before, I am already running it in Direct3D due to errors with OpenGL.

Regarding my GPU’s capabilities, it’s a high-end gaming card - definitely not underpowered. Further, disabling Aero causes significant errors in Photoshop CS5 due to their interface design being highly dependent on Aero features.

I’ve contacted support, and am trying to work out a time to have them remote into my system to see if they can’t figure out what’s going on.