Common Lip-sync problems

Hi everyone,

Here are some common issues that are related to the lyp-sinc module and sound synchronization.

Losing synchronization with long sound files:
Link to the Knowledgebase

If the following solutions did not solve your problem make sure to send a message and we will work our best to solve your problem as soon as possible.

Best regards,


Does anyone know if this issue refered to in the Knowledge Base Article has been addressed in v3.5?

I tend to have a lot of dialogue in my animations. Breaking audio files up into 24 second segments is not a very viable solution.

Hi Omegahed,

Unfortunately this bug has not been address in v3.5. Although I will see what can be done to fix this issue as soon as possible.

Thank you for your concern.

Best regards,


It appears that this problem has been known to the folks at Toon Boom for quite a while now. My first ever Toon Boom purchase is Studio 3.5 and I am upset to say the least. Not to have addressed it in Studio 3.5 is unbelievable and unforgiveable! I’m beginning to think I made a mistake in buying it! >:( >:(

i haven’t checked this one, but one general question:

i had problems with sounds that were full of pops after checked as ‘streamed’. the solution was to not to select any of the soundtracks into the timeline in the sound editow, but only to check the ‘streamed’ box and to leave the editor.

tbs guys, have you scrutinized the behaviour differences on that issue? maybe the sound synchronisation depends on that, too, who knows?
alas, i don’t have any appropriate project now to test the synchronisation, besides, my computer would need an upgrade in order to be a viable test environment…

Hi Zabrisa,

The lip-synching function has been made to analyze dialogues so the sound should be cut in pieces before importing them. Even when a character is talking for a while the problem with 1 frame dropped every 24 frame should not be apparent. This said, we still consider to look at the problem but the lip-synching function is working properly with elements that were meant to be lip-synched.

As for your problem Gester, there might be some specific settings in some settings of the mp3 format you have used that are problematic. We will try to look into it more deeply but in the meantime the best solution is to convert the file to avi or change the settings of your mp3 (after converting the mp3 file to wav we did not get any problems with pop and clicks in the sound).

Sorry for the inconvenience this might have caused you.

Best regards,


ugo, i don’t want to hijack the thread, but the wav size is some 10 times the mp3 size. a 30mb sound file instead of a 3mb is for the web a useless alternative.
i’ll check the avi conversion on the appropriate occasion, though. thanks.

Hi Gester,

We are still investigating on the exact cause of the issue for not all mp3 have that behavior so there might be something with the compression of some specific mp3. If by any chances you could provide us a sample of the mp3 that has the problem we will try to compare the setting with the other we have and see where could be the cause.

Thank you,


I purchased toonboom so that I could animate a character making long speeches. Is it advertised somewhere that the lip-sync function does not work for files beyond 24 seconds? I have not been able to find that on the website under “details”.

This is a serious bug, and the worst thing about it may be that it seems such a minor yet fundamental thing to fix. After all, it is called “sync”.

What is toonboom going to do to stand behind the product for those of us to whom this deficiency is unacceptable?




The desync may not happen in all situation. First thing you should try is to use a sound that is not compressed (.wav or .aiff). MP3 tend to have heavy compression which make the synchronizing more difficult to sustain.

Also you can cut your sound in multiple sequence and the issue will not be noticeable. Your sound track can be quite long if you have multiple sequence in it and you will not notice this.

Finally, make sure you have the Streamed option triggered.



ugh i can never get the syncing right with longer mp3s :frowning: