Color Question...

Whenever I pick the color i want and i try to change it, TB Animate Pro kind of locks up .I have 8 gigs of ram and a dual processor, on my other pc i have 8 gis of ram and a quad processor and it does the same thing. What is the problem I am using TB Animate pro…

I had the same problem for a short period then it totally disappeared.
But in my case it was only in the - Multi Wheel Mode.
Maybe try to change the mode of the color picker window to see if that helps.
For the problems I experienced I have no idea why it started or why it disappeared.Maybe it was due to minor updates of OSX. Me just running on 4GB of Ram, your Ram can hardly be the problem.

-Ivar

I’d actually like to get in on this, too. I have the same issue and it really slows down workflow. I use Toon Boom Animate 2 (build 7.9.0).

I have Windows 7 64 bit,
AMD Phenom II Quad Core 3.4ghz Processor
Dual Radeon HD5770’s (1gb video ram each) with CrossfireX enabled
16gb Ram (DDR3 1333, 4 x 4gb)

I have enabled Real Time Antialiasing and Full Scene Antialiasing in Animate’s settings and under my hardware’s AMD Vision Engine Controls I have “use application settings” disabled and set to 4x antialiasing. There’s nothing else I know of to set or try.

Everything else I do in the program is always super quick and responsive. The times it lags for several seconds per action is when I’m choosing colors between palettes, arranging palette orders, and editing, altering or adding colors, renaming colors, etc. Choosing between unaltered existing colors within the same palette is the only thing that is responsive speeds.

If I remember right, when antialiasing is disabled in Animate’s settings color selection regains normal responsiveness, but I like antialiasing mode way more and to constantly enable and disable makes coloring a detached, separated process.

You have to check your graphic card if it’s a supported model. On Windows the ATI have troubles. Their drivers are not consistent that is why they are not supported officially. On Mac it’s ok but not on Windows. So check your card because even if you have a fast machine it doesn’t mean that the graphic card will respond properly.

scizowdelarocha mentions that he uses Real Time Antialiasing. You should not activate that in most situation as it does a mini render of each stroke that you draw. Full Scene AA is good though. It doesn’t slowdown and you get the smooth lines.

Thanks a lot for the information. I’ll give disabling Real Time a try.


EDIT: Disabling the Real Time Antialiasing option worked completely. Although I noticed that camera view keeps that pixel by pixel soft-rendering while zooming in that I enjoy working with, drawing view doesn’t. It’s fine though, because now I know I can toggle the option if I really want relatively painlessly without need for restarting the program. I really appreciate the clarification, guys.

Are you running Windows or Mac? What’s your graphics card? Have you updated to the latest graphics card drivers?

~Lilly

Well one thing I can suggest here is that you don’t want to have both the Real-Time and the Full-Scene antialiasing on.

When you are using the Real-Time Antialiasing, what it does is it’s Animate itself that will calculate the antialiasing within the software.

When you use Full-Scene antialiasing, it’s your graphics card instead that will do the processing externally. It’s much better and more efficient to go with this instead. And this is where you would configure in your graphics card settings to set it to 4x, like you did.

So go ahead and disable the real-time antialiasing, so that you’re not doubling up on the effort.

If you are still experiencing these problems, please write in to support@toonboom.com so that we can investigate further. It may simply be something particular about your setup, but if not, let’s find out what is the problem so that we can fix it.

~Lilly