clipping mask troubles

I can’t seem to make the clipping mask work.

I followed the directions in help. I’m sure I’m goofing something up–I’ve always had trouble with this.

Here’s what it looks like in the timeline:

and here’s the result in camera view:

Oops… the Mask layer contains an edited copy of the cigarette, where most of it is intact and the finger area is deleted, so just the showing part of the cigarette. The Cigarette element is, naturally, drawing of a cigarette, a filtered light… Anyway, the picture shows the result. When I play it back it only shows the hand. I’ve turned show effects on and off in the View menu and I get no change.

Any help would be great.

Hi Rob,

Here is how it should be done. First the Mask shouldn’t be the cigarette but the actual hand (fingers). The thing that is currently happening is you are using the cigarette to hide some part of the hand instead of using the hand to hide the cigarette. When you are using Mask, the element that is under the Clipping Mask is the element that will be masked and the element under the Mask is the mask itself. The way the mask work is it shows everything that is in the painted area of the mask.

Now if you want the finger to be hiding some part of the cigarette you will have to make a mask that cover an area around the hand. Then from that mask erase the finger from the zone you painted.

The result might seem inaccurate on the display window but when you make preview you will see everything is fine

If you need more information send me an e-mail at and I’ll send you an example I made to recreate the effect.

Best regards,


I believe this calls for a “dduuuuhhh” or a “derrrr” or even a “no doy”, terms from my childhood that denote someone (moi) having missed the obvious.

I did everything right. I looked at the clipping tutorial that comes with Toon Boom. I wanted a mask that would hide the part of the cigarette being held, or really one that shows the part not being held.

Then I noticed that at some point I had turned off the cigarette element…

;DDoyoyoy… :stuck_out_tongue:

And, by the way, thank you, Ugo!