clipping mask problem

So I can get the clipping mask to work like I would expect it to but instead of being invisible it is a the shape that is masking but it is a grey color instead of the red I used for the mask.

I am on Camera mode, the mask works it just is grey and fills everything in grey.


The mask is only considered as shape regardless of the color. The matte (for the shape) should be under mask layer and the original image should be under Clipping layer. Check again and also check in rendered result if it is different from what you see it in camera view. If all the settings are correct but different result in Camera view only, there must be some display glitch for your video card. If it is Windows, change the display renderer type from OpenGL to Direct3D or vice versa depending on current setting from preferences>Display tab.