character pose template forgets z level and keyframe setting!!!!!!

hi folks

using harmony 12.2 - switching over from several years of using both harmony and animate pro in a rigger/tech lead role

Were having a recurring problem where on certain characters, the pose template (front, back, 3/4 front etc) when dropped onto the character master doesnt retain the z level and position settings that were keyframed in the rig file

This is our first series in H12.2, after completing several series, games and TVCs in both H10 and animate pro 2 and 3 - so im wondering if something has changed with the new release

normally we would make a master template by copying the master peg and character group from the node view into the library, then make pose templates by copying the relevant layers from the timeline at the frame where we have set everything position and z level wise

(this has been a tried, tested and reliable process for us for years)

But for some reason we keep having this keyframe info being forgotten when pulled back into new scenes for layout and animation

At first we thought it was due to those parts being set to “non-animatable” in the layer properties - but weve gone back, set all layers to animatable, keyframed EVERYTHING and rebuilt the library - with still no luck. Elements keep appearing in the wrong position and at the wrong Z level

Is there a better method we should use? Is it a bug? Is it a drawing layer setting?

Help - this is driving me insane

Really weird. Are you setting the z-depth on the peg of the drawing or the actual drawing itself?

I am not sure if this helps but have you tried putting it all into a group and then putting the group into the template library?

We usually only use pegs for upper/lower body splits, main face controller and character masters - so z depth is set @ drawing level

weve done it this way for over 5 years with no issues so its a bit of a mystery why its happening now

like a character master? - weve got one of those - its the different poses within the master that are causing the issue - and its only on the odd layer or two here and there