Can't see the control points

I’m animating a camera and I want to make it’s path a curve, for that
I’m trying to add control points but I just can’t. I pressed shift+F11
but I don’t see them anywhere I also tried pressing P after putting the cursor
on the path but no control point appears. Is it that I’m doing something wrong or anything else!!!
Please help!


From what I understand, you are able to display the path. Your issue seems to be adding the control points.

Control Points only work on 3D Paths, not Separate Position.

You have a separate path if the endings of your path (keyframes) are 3 colours: green, red, blue.
You have 3D path if then endings are yellow with red X.

You can also see that in the Timeline view and in the Layer properties view.

If it is the case, you will have to reanimate your Camera using a 3D path.

In the Animate Pro 2 User Guide, you can find the steps under:
Chapter 14: Creating Animation Paths Modifying a Path in the Camera View on page 603

Chapter 14: Creating Animation Paths Differences Between Pegs and Animated Layers > Layer Parameters on page 590

For Animate, you can search for the same titles in the user guide.

Let me know if it solves your issue.


I changed seperate position to 3d path and it worked!!!
thanks a lot ;D


You are welcome.