Can't open any saved files because of 'Unable to read .tvg' error

In the last few weeks I’ve been receiving an ‘Unable to read (filepath).tvg’ error every single time I open a saved file in TBH 12.

I’m using OSX v10.8. Harmony was working perfectly until about January, but now every drawing frame in every file I’ve saved since then gets the tvg error. When I open up the Stage I can still draw, still save, everything functions normally, until I close the file and then open it up again. Even though the .tvg files are there in the file folders, suddenly TBH can’t read them.

I’ve tried using both vector & bitmap drawing layers, the brush, the pencil, vector shapes: nothing works. I tried uninstalling and reinstalling TBH multiple times, I tried updating flash player and quicktime in case they had anything to do with it. This is happening on EVERY new file, and none of the file names have any strange characters in them. I don’t know what to do next. Can anyone can shed any light on why this might be happening?

I’ve noticed a few times in Windows that after saving a file, it would set the entire project folder to “read only” and I’d have to select the folder and set it back to read/write before it would let me load/save the file. I think in OSX you can check and change the folder/file permissions using File>Get Info. Hopefully it’s just that?

Great suggestion–I hadn’t considered it could be a permissions issue. Unfortunately I checked and everything was set to ‘read & write’ as usual.

However I did notice a weird trend: the TBH files created before january (which I can still view but can’t edit) have ‘read & write’ next to my user name but ‘read only’ next to ‘staff’ and ‘others’. But TBH files created after january (which I can’t view at all and are giving the tvg error) have ‘read & write’ next to all three. This is the ONLY thing that’s different about the non-working files than the working ones. I tried matching the permissions on a newer file to an older one but that didn’t work.

But as this is the only difference I’m wondering if it is indeed a permissions issue that’s been reset by a software update or something? I have no idea what the next step would be in identifying or remedying this, but it’s something.

1 Like

Anyone? I’m really struggling over here.

1 Like