cant nudge on Z axis - shortcut doesnt work


Several shortcuts do not work, most notably the shortcut to nudge layer order so that child layers visually appear over or under their parent layers in the Z axis. (all that seems to happen is that the layer moves on the X axis).

Another is the onion skin shortcut which also doesnt work at all, but not critical as there is at least a menu item for this.

I realise others have had similar issues but I cant find a solution.

Yes, I have checked prefences and reset short cuts to flash default.

And yes it doesnt work reagrdless of where the red box seems to be.

I really need this clearing up.



thanks Lilly,

Perhaps I am misunderstanding something here as I am new to this software. What I am trying to achieve is basically to place a hand visually infront of a forearm. As the hand is a child of the forearm it is currently visually behind the forearm. I assumed that in order to bring the hand forward (but still remain as a child of the forearm) I have to select the hand then Alt and arrow Down to bring the hand forward one place on the Z axis thus moving it forward and in front of the forearm. Is this not correct? If I am incorrect please could you tell me how I go about this thanks.

Also onion skin short cut does work at all.

thanks again for your help!


thanks Lilly.

Holding spacebar and then clicking to change window-focus works great-- another option is to go to Preferences–>General–> and then check ‘Focus On Mouse Enter’

–then whenever you move your mouse over a new window it will automatically get focus.

Both ways work well-- just personal preference.


I just tried it out on my machine here, and Alt+Down arrow works to move it forward, and Alt+Up arrow works to move it backward. You definitely need to make sure that the red outline (focus) is around your Camera View.

It just moves it a small amount, so if you’ve done bigger movements in Z in your Top View, then this small nudge won’t move it enough to overcome that, so make sure that your two layers are at the same z-depth when you nudge them.


No problem! I know this concept is a bit tricky when you’re getting started.

Indeed, you would select the child hand first. Thing is, most of the time when you select the child hand, you’re selecting it from the Timeline. Then the focus (red outline) is around your Timeline, and using the shortcut won’t work from here. So you need to get the focus around the Camera View.

You can either click on the grey part next to the tabs at the top to get the focus there without losing your selection, or a trick that I do is I just hold down spacebar (which brings up the hand) and click in the Camera View. Holding down spacebar while I click just means that I have the pan tool active, so I’m not going to accidentally lose my selection.

Onion skin is going to show the previous and next frames, and I usually actually toggle this on with the interface, not with the shortcut, but when I look at the shortcuts for Onion Skin there are a variety of them. The shortcuts may only work in a particular view, and that view is usually indicated by the category that it’s in. So if you want to toggle it on, you probably have to have the focus around the camera view or the drawing view.

I hope this helps, and if you need to you can always email for more help.