Can't insert key frames into Drawing Layers

Whenever I open Harmony the original Drawing layer is perfectly normal but when i add a new drawing layer all keyframe option are disabled. I can’t use any of the keyframe icons or right click to see other keyframe options. Anyone know why this is happening and how to stop it?

can you add a screenshot?

i can’t drag drop my screenshots.

But le me try and explain again.

whenever I create a new drawing using Ctrl R I create a new drawing (Vector) and when it is added to the timeline all the keyframe options from (Duplicate drawing) to (go to next keyframe >) this includes insert keyframe and delete keyframes

Yes, for some reason you can’t attach a screenshot into a comment but you can add a file to your first question.
I hope that works. Would be good to see how it looks.

i’ve added them


The images was very low res so it was difficult to see the details.

But from what I could see on image 2 the reason that all the tools were gray was because you had not selected any image layer.

Could that be the problem?

Hello !

Make sure the option “Animate using animation tools” is enabled in the Control tab of the layer properties.
If it’s disabled by default when you create a new drawing node, go to edit/ preferences/ advanced and enable the “Element node Animate using animation tools Default value”.

And everything should be fine.

Let me know, and change the title of the thread to “[SOLVED]” if it is ^^



no that isn’t the problem


this didn’t work but thanks

Sorry the problem is still there.

Maybe its best to contact toonbom support direct if you dont get any good answers here.

/ Mattias

It did work for me. Thanks!