Can't Import Video

I’m using a student license of Harmony 17 on Windows 10. I can’t import video. I’ve imported video various times before at school and work but it doesn’t work on the harmony license I have at home. When I try to import the .mov nothing happens at all. I find the file and click open but the dialog box shown here: doesn’t show up.

Things I have tried:

  • uninstalling and reinstalling both Quicktime and Harmony
  • converting the .movs to other formats
  • reinstalling Windows updates

Other info:

  • this happens with all video files
  • I can import audio and images fine
  • I was using Harmony 16 until today, when I uninstalled it and reinstalled 17 in an attempt to fix the issue

Any help appreciated! Thank you.

To go further into detail; you can navigate and find the video file, but when you click “import” nothing happens. Like, nothing. No import options dialogue, not even a spinning wheel or busy signal from computer. It just pops back into the stage view like nothing happened

Having the same issue with my students here for both mov and mp4. We’re on school run machines, however, so we can’t do the “repair” option easily without having a lab admin (and for each lab computer)

Is there a better workaround for this?

When you remove QuickTime did you restart the machine before installation?

Email me at I will be glad to work with you on this issue.

Best Regards,

Technical Support Specialist
Toon Boom Animation

I was about to uninstall and reinstall Quicktime again, since I can’t remember if I tried restarting in between last time. I noticed the repair option and tried it this time, importing video now works. Thanks Edgar!

The Quicktime options as seen on Windows 10:

Fun fact; this issue came up again, did a google search, found the forum post where I posted the same issue LAST semester.

Any help on this from support??

I forgot about this thread, but in case anyone else has this issue:
Not help from Toon Boom support. :joy: The IT team at the studio I was working at told me to reinstall quicktime 7 and that resolved the issue. They did end up having to send me a clean Quicktime download though, which I don’t have anymore. The one from Apple’s website didn’t work for me. Unfortunately I no longer have this file.