Can't import PSD files with separate layers in Animate 2

Every time I try and import a PSD file into Toon Boom Animate 2 it flattens all of the Photoshop layers into one image, even when I tell it to open it as an all layers image. I need some help here.

Every layer in Photoshop has to be in it’s own group…
Then import this file into Animate… Click Ok…
From the “Multilayer Image Import Settings” window select “All Layer Images”… click OK…

Otherwise, check Tutorial 6.3 Importing PSD files as separate layers:

I have the exact same problem:

I followed the instructions to the letter, but the imported psd is flattened.

What to do?

Are you using special- or odd-characters for your importing PSD-file-names ?

Otherwise, check those links again.