Can't Import Colored Images (ISSUE RESOLVED)

Whenever I try to import some .png backgrounds I’ve created for a scene, I get the following image:

"Error when writing image to C:/Users/Stanley/Local/Temp/ToonBoomSessionTempDir/40712/elements/IrkenCityscape_001RoughD.16/IrkenCityscape_001RoughD-1.tvg"

Just fyi, the filename is IrkenCtiyscape_001RoughD.png

This process won’t work on colored .png files. However, whenever I select the Vectorization to be in Grey rather than Colour, it works perfectly fine.

Does anybody have any clue on how to fix this?

UPDATE: I tried messing with the different vectorization parameters (i.e. I double-clicked on the “Grey” vectorization option to see what was making it work but color not work), and the problem is whenever ToonBoom Animate attempts to import an image and I’ve checked the “Colour as Texture” box under “Output.” It works whenever that box is not selected, but whenever it’s selected, there’s a problem (like the one mentioned above - of course, the temp data is different each time since, well, it’s temporary data, but other than that the error code is the same:

“Error when writing image to C:/Users/Stanley/Local/Temp/ToonBoomSessionTempDir/40712/elements/IrkenCityscape_001RoughD.16/IrkenCityscape_001RoughD-1.tvg”

(IrkenCtiyscape_001RoughD.png being the filename of the .png image I’m trying to import)


Update 2: Okay, all fixed! :slight_smile: Turns out the filesize was way to big. Thanks for your help, stevemasson

Could you try with a shorter name?

The png is in RGB color space right? I’m not sure if CMYK is even possible in png but just a thought.

Do you have free space on your machine?

Well, it looks like the filesize was way too large for it to handle in a single colored import. That’d be why it wouldn’t work. :slight_smile: Thanks for your help!

What resolution is the png?

The important factor by the way is the resolution not the file size because any image that is imported is uncompressed and put in raw format, if I remember well. Internally the image is treated like a 16 bit per channel so that we have the maximum quality at the output. So even if you had a small jpeg, file sized wise, it would be uncompressed to it’s full size internally. This takes a lot more memory in the application but guaranties the quality.

I think when it vectorizes in colour it has to do this, so it might have ran out of memory. Can you check if your memory consumption goes above the application (Animate/Animate Pro/Harmony or Vectorize) maximum? Windows is around 1.6 gig and mac 2.3 gig if you are not using Harmony 10.

What is the file size supposed to be?

I am getting the same error. But I am not sure what to check. The file size is pretty small - 1.5 MB.

Reread the last message by stevemasson