can't add a template at a given frame


I can’t seem to add a template at a given point in the timeline.

I can of course drag it into the element column and it will appear at the frame number it originally was drawn in.
But if I try to add it at, say, frame 500, it just doesn’t go into place. I can see a little + sign appear, as if it wanted to add. But then, when I let go, nothing happens.

I tried with the ‘alt’ drag but it didn’t solve it.

I must be doing something fundamentally wrong…


I’ve never had to do this but, I if I did have to, I think I would drag the template onto the timeline view from the library like I normally do, then probably … drag or cut N paste the cells to where I want them further down the timeline, and if needed extend the exposure.

I’m trying to visualize doing this cause I am not home to try it but I think I would try something along those lines.

I think he is trying to drag it onto a specific frame. I think what he is doing is dragging the template directly onto frame 500.

I just tried it and it works like a charm, so the key is that the template MUST have the same structure? that is good to know for future reference.


yes, Alex is right, I am trying to drop the template onto frame 500.
To be precise, I added a drawing and then dragged the template on frame 500 of that element. Nothing doing, it won’t.

You say I can place a template if there’s an existing structure. I suppose you mean I can drag a rigged character at a given frame provided all its elements and pegs and so forth are already there waiting. Nice, and good to know, but here I’m actually trying to do something simpler, really more basic.

The ‘template’ I’m talking about is, in fact, of the simplest kind. It is just a drawing that contains a piece of the credits I use very often (er… my name :slight_smile:
All I want to do is drag that in at a given frame.

All I can apparently do is drag it onto the left side, let it appear at the frame it originally was drawn at, and then, as Alex rightly noted, select it and drag it (or cut it and paste it) where I want it to be.
Basically, I have to do three actions in the place of one.

So the question still is: is there a way I can place a single drawing from the library at whichever frame I fancy or must I absolutely go through the ‘put-it-where-it-belongs-and-then-move-it’ procedure above mentioned?

All this may sound like I’m really lazy, but the need to place a drawing here or there is not infrequent, so if it could be done in one movement I think it would be that much better.

thank you,

Have you considered using a Symbol for your credits? Specially if it’s just one drawing. Symbols you can place into any part of the timeline from the Library, plus they are re-usable.


How I do it is, I have a credits template that I export as a separate scene (.mov) then when I go to compile all my scenes into one in Quicktime Pro I just place it at the end.

Of course I don’t know if you create separate scenes from your templates but if you do, this is the best way …IMO.

Hi Lilly

OK, I think I’ve figured it out. I already had followed the same procedure you just explained, and now followed it again.
I didn’t get it to go where I want it to, but I think I know why now.

The problem is the distance gap between the first frame of the template’s timeline and the frame the drawing actually appears.
The drawing with the signature I was trying to use was taken from a previous project. Since the signature is at the end of the scene, its frame number is quite high. Say, frame no. 1500.
I grabbed this drawing and put it into the library and named it ‘signature’, thinking I could ‘plop’ it wherever I wanted in a future project simply by dragging it to a specific frame.
I hadn’t taken into account a fact: Animate considers the point you are trying to place the template it as if it were frame 1 of the same template. So it actually DID go into the timeline, but the actual drawing was 1500 frames ahead. If I placed it, say, at frame 1000, it appeared in reality at frame 2500. And thus, I couldn’t see it.

Solution: I prepared the a new signature drawing on separate project, on frame 1 and then added it to the library. Then I went back to my current project. Now, when the pointer drags it from the library to a specific point, the software thinks: “frame 1 = frame 1”, and the drawing falls exactly where I want it. Basically, if there aren’t any empty frames before the drawing in the template, you can place it wherever you like. If there are, you have to take them into consideration.

Good to know, although it’s one of those things you don’t figure out right away (especially if you’re making a deadline)

I hope I explained it correctly… does it make sense to you?


What AlexF suggests, to use Symbols, sounds like a good solution!

Adding the credits later via montage would also be a good way, in fact I do use that sometimes, but its practicality depends on how the credits tie with the end of the film; and in general I like to keep as much as possible editable within the main project. Especially when working on small minute-long projects.

So, yup, Symbols is the way I think I’m going to go on this one.


Aha, true, I hadn’t thought about that. So maybe I’m actually better off using drawings.

In the big picture, I think the mode should be: drag a template onto the layer zone, it will be placed exactly as it was when it was created; drag it onto a frame, it will be placed where your cursor is, coinciding with the first frame of the artwork.
That would seem perfect to me, as the first case re-creates the template’s original frame asset, but the second would let you override that for specific placements.


There are two ways to drag and drop a template. Either you drag and drop it onto the left side of the timeline - this should drop it at the beginning. Or if you drag and drop it onto the right side of the timeline - directly on top of the frame where you want it to go - then it should plonk in at that frame.


You should be able to do that. Now the only thing is that with a template you can only drag and drop a template onto an existing structure that already matches the template you’re currently trying to drag in. So you would need to have dragged the template in once already to get the folder structure, then you can drag and drop it back in as many times as needed by dragging it directly onto the desired frame.


Indeed, that is the key, the template MUST have the same structure. :slight_smile:


What might be happening here is it might be because of your Drag options. When you drag and drop a symbol by default the option is to “Only Create Drawings when they do not exist”. You might want to take instead the option “Always create drawings”.

I just ran a couple of tests and it worked for me with either option, actually. So here’s what I did:
1) I created a drawing layer onto which I wrote my credits.
2) I dragged and dropped this layer onto the library.
3) I created a new layer - this is my destination layer where I want to drag and drop the new credits onto - picture this as an empty layer in a new scene, if you like
4) I dragged and dropped the credits onto the new layer at frame 100 and they dropped in just fine.
5) I also tried changing my drag options. When dragging onto frame 100, instead of just letting go, I held down Ctrl then let go. This brought up my drag options and I could choose “Always Create Drawings” in the Advanced tab.

Just be aware that when you change your drag options, they will stay as however you change them until you change them again. So if you change it to Always Create, it will stay on Always Create every time you do a drag from now on.

Hope this helps.


Problem with using Symbols is that you won’t be able to access your symbol from a new project.

What you said about the template coming in on frame 1500 makes perfect sense. I’m glad that we found the solution to your issue!


But that is exactly what it’s doing - it’s dragging it onto the frame where you have your cursor. But if you have a blank space at the beginning of your template, it can’t determine that the blank space is irrelevant - there are some situations where this is not the case. You might have strategically placed blank spaces in your template where the exposure is turned off. So you should create your template and then remove the blank space by doing an Edit Template.