Camera moves always in curves! :(

I can’t get the camera to do a straight linear movement.

If I zoom, it first pans to one side on the X or Y axis and then centers again.

If I move sideways, the Z axis zooms and then goes back the original value.

There’s always a curve, a hump in the movement.

Why is this? All I want is a simple basic linear move, but it just won’t do it.

Help needed…

thank you,

Hi Nolan, thank you.
Unfortunately that didn’t work. The curve between the two Keyframes of the camera is already a straight line. I clicked on Reshape to Linear Segment anyway, but nothing changed.

Why should the camera put a curve in a move in the first place?
I can’t get any cam moves to not do this, so my film is forever slightly panning or zooming unnecessarily. It’s maddening.

Thanks for the ear. I wonder if anybody else is having this problem.


have you got 3d path for the peg for the camera?

Try switching that off?

Hi Theraider

The checkbutton ‘Enable 3D’ at the top of the ‘Layer Properties’ panel is OFF.

The checkbutton ‘3D path’, under that, next to ‘Separate’ is ON.

If I check ‘Separate’ I lose all camera moves in the whole movie. It just goes back to a fixed default state.

Animate is just refusing to do the simplest, straight camera moves for me. I don’t doubt it’s my fault, but I can’t think of anything I did to make this happen. I started with a clean file, did not use 3D paths, did not really try anything complicated.


Go to view- show- control- in a side view or top view select the key on camera path, go to coord.and control points- control points and keyframe- set the tension to 1 instead of 0.

Hi tomicic

thank you for the answer.
I followed your instructions up to the coord. and control points window, but the option to set Tension from 0 to 1 is dimmed. I cannot select it, cannot change it.
I looked everywhere, I am really at a loss now. And getting worried: I have a deadline and film chock-full o’ curving camera moves I can’t get rid of.

Why the #°*@ does animate do this??? Shouldn’t it create curved camera moves only when you expressly ask it to?

This is driving me crazy… :((((


Hi again, tomicic.

I seemed to get somewhere by clicking on the control point in Top view.
That let me change tension from 0 to 1, and the move is straight now.
Great! Thank you very very much! :slight_smile:

Still, that leaves me with the question why Animate should add that curved movement (or tension) in the first place.
I don’t think I did anything to ask it do this, but if you know what the causes is, could you tell me so I can avoid this happening all the time?

Thanks again,


I am curious, if you go to your preferences and click on the Camera tab there is a Control Points field that lets you set Tension, Continuity and Bias.

I believe the default settings are 0, 0, and 0 for the TCB. So, this may be why it is doing this.


Hi Lilly,

I only don’t understand why If I drag the camera holding SHIFT and therefore create an absolutely straight line, I should be getting random curves I don’t want.
Just now, I dragged the camera to pan from left to right holding Shift. The simplest movement of all. And hey, I get a hump (in the Z plane, so between start and end positions I get an ugly zooming effect).
I can’t figure out why this should be.
Can I deactivate the 3D path so it won’t do this anymore (unless I want it to)?

Sorry, I guess I’m not grasping a lot of this…

thank you very much,

I know a method. very convenient method.
see picture:

Thank you for the advice, zzl_662! :slight_smile:

I although still don’t grasp why I should be getting camera curves in cases where I clearly didn’t ask for them.

thanks again,

By default in the software it creates curves between the different keyframes.

Another quick and easy way to avoid this is simply to put a control point one frame over from your keyframe, and this makes it a straight line.

This only happens with 3D path, but the advantage to using 3D Path is that you can get more robust camera moves if you have things like rotations.


It’s because of the way the functions work on a 3D Path. If you have two keyframes directly next to each other, or a keyframe with a control point right next to it, then it makes a perfectly straight line.

The easiest thing is to probably just have it create pegs with Separate by default. You can set this in Preferences > General > Default Separate Position for Pegs.