Camera issues

Alright, camera is moving however it pleases, again.

So I did a 3D truck-in with x, y and z movement with the camera(as usual, the camera tried to curve a straight path, so I just added another keyframe right beside the first keyframe), I managed to make it work fine. That shot is done, but then I add a keyframe (in the camera peg layer) in the next frame and the trayectory of the last ‘tween’ has been modified.

So basically I’m just trying to animate a whole dialogue here which has several shots; I do not wish to make a new scene and avoid the bug.

I’m including some images; first image is how the tween is currently (working). Second image, I add a new keyframe and somehow it affects the (working) tween.

http://dl.dropbox.com/u/5928749/1.png
http://dl.dropbox.com/u/5928749/2.png

I don’t know if it matters, but I am using a Mac, with LION OSX.

From looking at your screen captures it appears you have a camera attached to a peg and then that peg attached to another peg. Is that what you intended and what is the reason for the second peg?

Years ago when I did a little (very little) 3D work, I would sometimes have a camera or an object attached to a null and then attached to another null. The idea being that I could animate the trajectory or motion with one of the nulls and then add some jittery, secondary type of motion with the other null. It was setup in a hierarchy like how we can have pegs nested.

What happens if you just have the camera attached to one peg and animate that?

-Mark

Oh right, I added that peg to try and fix the camera on that layer, but it didn’t work either, so that peg layer isn’t doing anything. I’ve just deleted that peg and the same issue is there. Thanks for pointing that out though.

this may help:
http://www.toonboom.com/support/forums/animate/index.php?board=15;action=display;threadid=3148;start=msg15196#msg15196

Thanks Amin, yes, I’d had seen that post before, but I couldn’t find the Toolbar Manager to access that tool. How do you bring “Toolbar Manager” onscreen?

I’m using Toonboom Animate, not Pro though.

i am also using Animate not PRO, and couldn’t locate a tool bar manager. however, when i encountered a similar problem, it was Bobolosh’s solution in that thread that worked for me: i go to the start key frame of the undesired curve, i select it on the camera/side/top view, then i change the tension from 0 to 1.
the other option is to change the peg layer settings, specifically, to change the “3D path” to “separate” after double clicking the peg layer. this however, will cancel all your previous camera movements and you won’t be able to have any curves even if you want to.

try changing the tension of the start keyframe to 1

Thanks everyone for the advice, but the issue persists, maybe I have to be a bit clearer since it is quite a complex scene:

So, I’m having a 3D truck-in: I’m moving the the camera all axes and curving the trajectory (x,y,z). Since the shot is from inside a vehicle, I need that exact camera movement copied into another peg where the interior of the car and the characters are.

I’m including two images to clarify:
http://dl.dropbox.com/u/5928749/camera1.png
http://dl.dropbox.com/u/5928749/camera2.png

So this is what I did first:
I did the camera movement first, but it started with an odd curve which I did not plan, so I added another keyframe immediately after it (this made the planned curved move as planned:
http://dl.dropbox.com/u/5928749/1.png

Then I copied these keyframes and pasted them unto another peg layer (the layers for the seats, characters and dashboard) and the movement of the camera and this peg was identical, everything worked perfectly.

So I proceeded with my next shot, it is here when the problem emerged. I placed a new keyframe for the camera and this somehow altered the last camera movement.
http://dl.dropbox.com/u/5928749/2.png

Why is adding a new keyframe altering the last camera movement? What can I do to avoid this?

1- Yes I could do that (technically) but somehow that also doesn’t work: the dashboard disappears as well as the seats once they pass the horizontal white line in the “top” view:
http://dl.dropbox.com/u/5928749/nodashboard.png
http://dl.dropbox.com/u/5928749/noseats.png

2- Yes, I’ve set the tension to 0 in x, y and z axis:
http://dl.dropbox.com/u/5928749/notension.png
(I’ve only included the image for z, no need posting all axes)
The tension is set to 0 in all keyframes.

Alright… I get what you mean with the child and camera peg, but that’s the odd thing:
Copying the keyframes from the camera peg unto a new peg layer for the character and car layer doesn’t make the character disappear… but placing them as a child does… when crossing the white line shown on the top view…

Yes… it makes no sense, but that’s the odd thing…

Well I also tried bringing the toolbars you mentioned, the “Control Point” and the “Coordinate” toolbar; the ‘T’ appears as 0 in there as well, but the box appears grey and does not allow me to enter values for it. I had never used this toolbar so I don’t really know if that’s how it’s supposed to work.

Anyways, this issue is going a bit out of hand… what I’ll probably do is to export the chunks separately and composite them in a single shot…

First of all, you could just drag and drop your characters and car layer onto the same peg as your camera, so that they all share the same peg. Then they’ll be exactly the same.

If I understand correctly, when you add a keyframe, it’s changing the path. This should have something to do with the tension, because it puts a curved path between the two keyframes, it will adjust the curve to take this path seamlessly.

I’m not sure if I’m explaining this very well, but did you try setting the tension to 0?

Well when you make them a child of the camera peg, if there’s any transformations on those layers, those will be added to the transformations on the camera peg. So you may have to make an adjustment, perhaps using the Maintain Size tool to move your drawing layers closer to the camera in the Top view, so that they slide in front of whatever layer is obstructing them.

So you know an easier way of setting the tension to 0 is just to select the keyframe that you want to adjust. Turn on your “Coordinates and Control Points toolbar.” When you select a keyframe or a control point, you can control the tension, bias, and continuity on that keyframe from there.

You can also do a View > Show > Control on your camera peg to show the path of the peg. Then you can make adjustments visually on the path. If you have a 3D path, then you can mouse over the path and hit P to add a control point. Dragging control points around will help you to shape the path.

Hope this helps.

~Lilly

For those fields to not be greyed out, you need to select a keyframe or a control point. It’s just another way of working.

That is wierd indeed. I’m not sure exactly what those grey cross-hairs on the top view are representing. At this point it may be easier to take a look at the scene file, so if you continue to want assistance, then email support@toonboom.com so that they can help you find out what went wrong.

~Lilly