Bug: Drawing layer in front of every thing

The drawing layer is always in front of others drawing layers in CAMERA “OpenGL View”, but in “Render View” it stay behind (the correct place).

In my rig all composites is in “Pass Through” but the back hair appears in front of body in Camera Open GL view, but in Render view it appears behind, this hinders when animating the character.

The axis z is (0.0011 B) teorictly putting the drawing layer automatic behind of everything, but it doesn’t matter if the axis z is 9.9999 B or whatever number, drawing layer always is in front.
Can someone help me?

It might be due to one of these two preferences in the OpenGL tab:

1 Like

thank you so much, i have been having this problem for some years but it was merely aesthetic, this time turn a big problem to animate the character, you save me, thank you again