Brush Lag Problems

Hey, so I’ve recently downloaded Harmony 12.2 and it seems very promising, except I’m experiencing a large amount of brush lag. I’ve disabled full scene antialiasing but that didn’t have any effect. I’ve also tried to uninstall and reinstall but that didn’t make a difference either. I’d love to never have to use Flash again, but I might have to stick with it if I can’t solve this problem.

My computer Specs are:

Macbook Mid 2012
8gb ram
2.3 GHz Intel Core i7
NVIDIA GeForce GT 650M 1024 MB

Any help would be greatly appreciated, thanks!

I’m having a similar problem. The brush tool is lagging, but strangely does not lag when I switch to Render view. Using a MacBook Pro. I was using Toon Boom yesterday, and it was working fine, but now it’s malfunctioning.
Would be great if someone finds the solution for this. The lag is unbearable.

The other way round, right? Render view is for checking the final look or to see some effects that won’t display on OpenGL view. In render mode, each time you make a change, the software will process it’s final look (recreating the frame as it will look when exported), so for most operations it will not work in real time (depending of the operation or effect and your system).


Luis Canau

Nope, drawing in OpenGL is practically impossible. Render Mode’s processing is much more bearable than OpenGL’s lag. I know it’s kinda of a backwards work around, but right now it’s the only somewhat decent solution I can find. Maybe it’s an issue on my end, but I am kind of disappointed in Harmony’s performance. I’m sure this is just a weird isolated occurrence, but it’s still slightly annoying.

Generally it is turning off antialiasing that makes lines more jagged. You can utilize OpenGL with or without anitialiasing. Turning antialiasing off will provide some relief for a weak graphics card.

Jordanbrodie,

Have you tried using OpenGL mode with antialiasing unchecked in Preferences?

I could not run Harmony on my Mac Mini but it runs Animate Pro 3 even though it does not meet minimum requirements. The Mac Mini is similar in specs with your Macbook. You have the 650M but I have the 320M. There is more under the hood and accessories all around in Harmony but they do share enough that it is worth noting cursor lag while drawing has not been an issue even when Full Scene Anti-aliasing is checked. I switched to unchecked for other reasons, more preemptive than to resolve anything.

That’s peculiar, maybe it’s an issue with the graphics card? I don’t think it’s normal to be able to work better on the render view than on the OpenGL view. I worked with Mac Pros from 2009/2010, some with less than 8 GB RAM, AMD GPUs, there was no drawing lag on any of the stations. The most difficult would be trying to play the scenes in real time and when rendering effects, such as blurs or heavier ones. I’m currently working in recent PCs with decent specs in 4K with bitmap brushes and there’s no lag when drawing, so I don’t think the software itself has performance issues.

Have you tried switching the scene to a really low resolution to see if that still happens? If the lag is the same, let’s say in HD and in ‘low’ or 240p that might suggest the issue is not only related with your hardware specs. Do you notice problems with other software? Premiere, for instance, seems to be be more heavy on your system than Harmony.


Luis Canau

What brush are you using? it happens with any brush? Vector or bitmap? HD or lower resolution? Some bitmap brushes, for instance, water colour, are a bit heavy on the system. I have the same processor and similar GPU on my laptop (PC from beginning of 2014) and I only notice a bit of lagging on some complex bitmap brushes. Note that the system requirements consider these specs “average”. http://www.toonboom.com/products/harmony/system-requirements


Luis Canau

Thanks for the reply. It happens with every brush, regardless of whether its vector or bitmap. I’ve tried to change the resolution to as low as 240p but it lags the same amount as it does with 1080p.

In Camera View do you have the OpenGL View Mode selected or Render Mode? They are the little flower icons on the Camera View bottom toolbar. Drawing with the Render Mode selected will cause lag. Drawing with OpenGL will make the lines looks jaggy but there should be no lag at all.

http://docs.toonboom.com/help/harmony-12/premium/Content/_CORE/_Workflow/008_Interface/006_H2_Camera_View_HAR.html

Also, what are you using to draw? Are you using a mouse? Tablet? If you are using a tablet, which brand?

Hm, so I was drawing in OpenGL View Mode and it was lagging terribly, but as soon as I turned it to render mode it stopped lagging. Weird, but if this permeatly fixes it, I’ll take it. I’m using a Wacom Intuos Creative Pen & Touch Tablet (Small) to draw.

Thanks for the reply!

Hey, I am harshit… and I don’t know why but the same problem was repeating with me too. But I found a solution.

When I was drawing in toom boom animate 2 pro the brush lags and I have to wait almost 2 to 3 seconds to see what I just drawn. But than I noticed something. Whenever I zoom out, the brush works pretty well. But as much as I zoom in, the brush starts to lag. Maybe it’s because toon boom have to render lines more clearly because of zoomed view and graphic card isn’t strong enough, So the lines becomes lagging.

So to solve the problem I just simply decreased the brush size whenever I am drawing some close shots while zooming. It worked for me, hope for you too…