Blur edges only

Hi there,

I there a way to achieve that?
I’ve tried several blur-modules, but they always blur the entire drawing.
Unfortunately, enabling paper texture in the brush settings and decreasing the hardness down to 0% doesn’t suite my needs.

Then I found this tutorial here:

but since I can’t find a feather tool in Harmony it apparently doesn’t work there.

Is there an alternative approach or is it simply not possible in Harmony?

Thank you!

Howdy, If you use a Gaussian-Blur it should have a Matte input port. In that tutorial example you could take the sun and in Harmony use a Gaussian Blur. Copy the stroke of that sun into a new drawing layer and play with the stroke of it, increase it, etc. Use a black stroke and input that into the Matte port. Then when you adjust the blur amount it should only blur what is contained in black in that Matte drawing.

Doesn’t have to be a stroke, you can make any kind of object, here is a case where I just used a circle with a black fill to limit the blur effect.

Or you can just take a brush and draw with black in that Matte and it will limit the effect of that blur. You can even give that Matte a Blur to get some gradations or feathering like in that tutorial. Here is my attempt to soften that hard circle:

That Negate module that is unattached I was experimenting with to have the matte inverse so that it was blurry just on the outline of the sphere. I attached it after the Matte’s Blur module and before inputing it to the final Blur. I think I am confusing myself now, sorry, hope that helps some.

Feature request: Blur-Edges module.

Similarly to what scungyho suggested, you could achieve the effect with the Matte-Resize - Negate - Cutter (inverted) connected to the Blur-Gaussian matte port, using the drawing as the matte source. You could use the Matte-Resize to increase the area of the drawing you want to blur. You would add a blur to the matte and that’s five modules, more than the previous solution. This option has the advantage that you can save it on the Library and use it with any drawing since it uses the art’s own matte.

You could also use the Blur-variable with an adequate matte.

Luis Canau

Icanau, now that I am looking through the modules, it looks like maybe the simplest thing is to do a Matte-Resize and a Matte-Blur that connects into the Blur-Gaussian matte port. It is so easy to just overlook or just not find things at first glance when going into the Node Library.

That Matte-Blur is nice because you can choose Radial or Directional, change the radius of the blur, you can choose Directional and then choose a directional angle and falloff rate, and you can invert the matte all within this modules properties.

The thing I don’t understand is the issue of the bounding box. If you are applying the blur to say this simple circle scene of mine, the blur gets cropped at the bounding box. I for the life of me can’t remember what I did in the past to make this not happen. I could put a small brush mark in the top left corner away from the circle and do the same for the bottom right corner to increase the bounding box of the circle, then I can give those two marks a different, unique color and use a Color-Override to make them invisible. But that seems like a lot of work to do, isn’t there a better way? A magical checkbox in the the preferences?

Sorry for my late response, haven’t checked the forums for days now.

Well, I’m very happy about all of these suggestions, thanks for that. I’m currently trying these out.
But to be honest I can’t get it to work right now. I’m trying to follow Icanaus’ steps but I guess I’m not connecting the modules in the right order.

So would it be okay you guys if you make a screenshot of your module setup like scungyho did in his first post (which was awesome)?
Finding it quite difficult in text form right now. However, being able to save it as a template in the library sounds amazing because I’m going to need this feature for a couple of more drawings in the future.

I finally got it managed according to scungyho’s screenshots. That’s perfectly fine for now!
But I’m still interested in Icanaus’s method since you can store it in the library.

Thanks again. Great support.

I recorded a quick video with ScreenFlow and showed a different setup than the screenshots I had posted earlier.

Wow, didn’t expect so much effort. Thanks mate, I appreciate that. EXACTLY what I needed and it works like a charm. Great video and very well explained!

The problem is that the Blur-Gaussian node cuts the blur with the matte of the original drawing, so that cuts your blur if it goes out of the borders. What you did on the video, using the Colour-Override, is a good trick. You can also just draw a couple of dots with invisible colour (changing the alpha to zero) or using the Stroke tool to create invisible lines. That way you won’t need to add the Colour-Override module.

To avoid this issue we would have to isolate the area we want to blur in a way that the original art matte won’t cut it. That means a number of modules. You can, for instance, use peg-apply modules to increase or decrease the matte of the original drawing (one advantage is that you see the result on the OpenGL view, unlike the Matte-Resize/Blur). You could use one peg-apply to increase the matte and another to decrease it, to create a border area based on the original art that you can blur over the original art.

It would be nice to have a Blur-Edges module on Harmony 14. :slight_smile:

Luis Canau

Okay there’s still one last issue I can’t get rid of.

Here’s a rendered version of my drawing:

Everything which is below and to the left of the arrows is an overlay graphic on which I applied the blurred edges.
The blur is not visible in that area right now as it is cutting the drawing underneath, but it actually contains the blur-modules as shown in your video.
It’s just a cutter-module in addition, that’s why it’s sharp.

However, as long as I plug in the cutter I’m getting these dark outlines around the drawing.

Is there any chance to prevent that?

Hard for me to say, any chance you can post a screen capture of your node view?

Alright got it.
Seems like it’s a common problem with cutters (see and has nothing to do with your blur method.

I guess it’s related to Anti Aliasing. Since both drawings are colored differently, some pixels of the underlying drawing peep through, which causes this effect.

I got it fixed by painting the edges of the underlying drawing in the same color as the cutter.

It might not be a perfect solution but it did the trick.


I tried following this tutorial, but I can’t find the “Tools” whatever to bring up the Feather Edge dialogue box and it’s driving me insane. It says click “Tools”, but where even is that? Is it the Tools window? Because I always have it open, so it can’t be there. It’s probably right in my face, too, but it doesn’t even specify where this “Tools” thing is, which is especially annoying because it spells out everything else. I’m using Harmony Essentials, by the way.

A little help, if you please?

Thank you.