Bizarre Curve Mode problem.

So I’m trying to rig up a curve deformer for my character’s hair. I follow tutorials, both from the site and on youtube that tells me to do basically the same as when I rigged up the bones for her limbs, but when I do, the entire curve switches place.
I’ve attached some screens that illustrate the problem.

I’ll start by placing the first point by the root of her bang( s ), drag out to create the handle, then do the same where I want it to end. But as soon as I release the second point, the whole thing suddenly goes from being positioned where I intended it to be, to being positioned somewhere where the second point is higher up the bang, and the first one is down by her torso. Neither of which where places where I clicked. The same happens if I try to just do it from the tip of her bang to the lowest point. The entire thing is suddenly placed down by her neck and shoulder. What on earth is going on?


Hard to say without seeing, i assume a higher peg is messing up the order location somewhere. If you can post the project file i can take a look.

Sure. Here’s a link.
Sorry about any potential shabby layer-work. It’s my first real attempt at a rig.
Also, most of the layer-names are in norwegian, so if you have any questions in regards to that, just let me know…

You need to upload the entire folder where the xstage is located (go up one directory and put that folder in a zip file). The xstage alone doesn’t house the colors/images/etc.

Oh. Right. Here, this should do the trick. I hope.

Try to put an kinematic outputs between a deformer and other pegs. Try adding one above the Hairlug peg. The Kinematic output can be found in the module library.

As Stacey said, you need to put a kinematic output node to prevent the deformer of chest making problems for the hair, once you do that it works with no issue:

That being said there’s several comments on your rig.

First of all: disable the animate button when youre building a rig (it’s the running man icon). Putting keyframes as positions instead of natural placement is gonna cause you headaches in the future. You can keyframe the entire view once everything is in position as drawing layer location.

Put parts of the rig into their own composites. Make a composite for head, put all the stuff there, for hand/leg/body/etc, and then connect them down to a main comp which then connects to stage comp.

Don’t make a seperate mask for the eye iris like you would in flash, it’s unnecessary and complicates. Instead use either auto patching, layer select or colour override (or all 3) to bind the iris inside a color that only appears when this drawn (so if you erase part of the white and draw a line it will only show up within the white).
Make the whole thing a group once its fully together (as well as group up separate parts that are with head/body/etc comp).

Disable animating on layers, make all movement be based on pegs only as it’s gonna cause you headaches once you’re animating and moving an arm that will effect all your other frames (also you have rotation points on parts in one location and then the pegs point in another, it’s gonna be a lot of problems).

Basically go here and select toonboom harmony and do the entire rigging start to finish tutorial. It will go over all the aspects of cutters/color override/autopatches/etc.

Thank you so much for the feedback.
Great help. :slight_smile:

Thank you. Really appreciate it. :slight_smile: